Odoo Help

0

CSV import : how not to update a record's field ?

By
HIGHCO - Nicolas Clavier
on 8/4/16, 9:12 AM 599 views

Hi,

When uploading partner updates from a CSV file, the "name" column is filled for every record which I want to update.

Some record I want to leave as is in odoo.

Problem : if I leave the cell blank in the cvs, odoo erases the name of this record (actually sets it to "")

I have tried to enter "0", 0, False, "False" to no avail.

So what value should I enter in a CSV file's cell so that it is ignored when odoo processes the file ?

external_id
name
notes

__export__.res_partner_2


Do not update the name

__export__.res_partner_3

John Doe

set the name to "John Doe"

Thanks for your time.

Nicolas

0
Ajeet Yadav
On 8/4/16, 9:20 AM

You can leave same name as in odoo. Don't change name in csv for which  you not  want to update.


hi, It's an option of course but I'm not in an export -> re-import scenario, data comes from another source. Thanks.

HIGHCO - Nicolas Clavier
on 8/4/16, 9:27 AM

are you updating only name field or other data also?

Ajeet Yadav
on 8/4/16, 9:35 AM

The same issue arises in many other columns.

I get random value updates in random columns... So all columns should be ignored by default or updated if any data is provided.

HIGHCO - Nicolas Clavier
on 8/4/16, 9:39 AM

About This Community

This platform is for beginners and experts willing to share their Odoo knowledge. It's not a forum to discuss ideas, but a knowledge base of questions and their answers.

Register

Odoo Training Center

Access to our E-learning platform and experience all Odoo Apps through learning videos, exercises and Quizz.

Test it now

Question tools

1 follower(s)

Stats

Asked: 8/4/16, 9:12 AM
Seen: 599 times
Last updated: 8/4/16, 9:20 AM