Odoo Help


Creating tables with %for and %endfor in email templates - Odoo is putting my loop outside the table, not inside.

Anti Nuga
on 8/10/16, 9:49 AM 1,108 views

If I try to make a table for an email and use a loop in it:






% for comp in object.component_ids:





% endfor


And as soon as I save it, Odoo takes the % for and % endfor out of my table and puts them front of the <table>. Any idea why?


Jérémy Kersten (jke)

--Jérémy Kersten (jke)--

| 3 3 5
Jodoigne, Belgium
--Jérémy Kersten (jke)--

Jérémy is a member of the core R&D team since september 2013. He developed several projects for OpenERP version 8 including the eCommerce, the Google Calendar synchronization and the new product variants/configurator. Now, he manages Odoo website and themes for saas.

Jérémy Kersten (jke)
On 8/10/16, 4:50 PM

Change the widget_html to widget_text... it should works :)

It is because the browser auto correct the html... and it is no valid to have node text between <tr> tag


please can you explain where can you change the widget?

on 6/3/18, 8:39 AM


Enable debug mode in setting, go to the view you want to update

At top right click on the bug icon -> edit form -> replace widget='html_frame' by widget='text" for the body field

Jérémy Kersten (jke)
on 6/3/18, 8:53 AM

About This Community

This platform is for beginners and experts willing to share their Odoo knowledge. It's not a forum to discuss ideas, but a knowledge base of questions and their answers.


Odoo Training Center

Access to our E-learning platform and experience all Odoo Apps through learning videos, exercises and Quizz.

Test it now

Question tools

1 follower(s)


Asked: 8/10/16, 9:49 AM
Seen: 1108 times
Last updated: 8/10/16, 4:50 PM