Odoo Help

0

Countless problems with wkhtmltopdf and webkit reporting engine

By
Chris Jones
on 7/17/14, 11:23 AM 3,913 views

I've been trying to get the webkit reporting engine to work for quite literally 8 months. Started with QT errors, then worked and with no changes broke again. 

Ubuntu 12.04.4 LTS 64 bit. Latest report_webkit module. 

wkhtmltopdf 0.12.1 installed in /usr/bin, I've also tried 0.11, 0.9.9, 0.9.6 and a few others. 

webkit_path variable set in OpenERP db. 

wkhtmltopdf https://www.google.com google.pdf - this works fine from a command prompt.

Webkit error

When I try to print the report in OpenERP I get this error. I'm not running Apache as a proxy but I checked the ssl.conf file anyways and in it SSLv2 is disabled. 


The command 'wkhtmltopdf' failed with error code = -11. Message: The following diagnosis message was provided:
QSslSocket: cannot resolve SSLv2_client_method
QSslSocket: cannot resolve SSLv2_server_method

At this point I'm about to give up on webkit permanently and switch over to Aeroo Reporting Engine. Ideas? 

Hi Chris, From my understanding regarding the issue the following package needs to be installed: libssl0.9.8 please refer to this github issue: https://github.com/wkhtmltopdf/wkhtmltopdf/issues/1516 Give that a go first and post back if this is the solution as it will help others having the same issue. If that does not fix the issue I'd recommend posting the contents of your openerp-server.conf file (minus the private items like password and IP) and provide a little more detail regarding your server environment?

Luke Branch
on 7/17/14, 10:58 PM

About This Community

This platform is for beginners and experts willing to share their Odoo knowledge. It's not a forum to discuss ideas, but a knowledge base of questions and their answers.

Register

Odoo Training Center

Access to our E-learning platform and experience all Odoo Apps through learning videos, exercises and Quizz.

Test it now

Question tools

2 follower(s)

Stats

Asked: 7/17/14, 11:23 AM
Seen: 3913 times
Last updated: 3/16/15, 8:10 AM