Odoo Help

0

Couldn't find static files when installing OCA module web advanced_search_x2x

By
Alexander Soare
on 11/4/16, 11:30 AM 337 views

I have Odoo 9.0 community edition and tried to install this addon:

https://github.com/OCA/web/tree/9.0/web_advanced_search_x2x

I had to make one modification and that was to change "installable" parameter in "__openerp__.py" to True.

The problem is that my browser logs keep telling me that the js and css can't be found.


http://localhost:8088/web_advanced_search_x2x/static/src/js/web_advanced_search_x2x.js 404 (NOT FOUND)

http://localhost:8088/web_advanced_search_x2x/static/src/css/web_advanced_search_x2x.css 404 (NOT FOUND)


What is the problem here?

0
SonnyV
On 9/14/17, 5:13 AM

This has probably already been solved, but since it is an open question I will try to answer it anyway.

I think this might be caused either because the files are not added to the assets. But after checking the github, this can be ignored, since the xml clearly adds the js and css to the assets.

Another problem might be that you copied the files over as root, but run Odoo as another user and the user might not have access to the folder.

Yet another reason could be that the module was moved, and it is no longer in your addons-path, therefor the files could not be found.

Now, as I mentioned earlier I checked the github and noticed that there have been a few adjustments since this question was asked, so it might also be possible that it was just a faulty module back when this question was asked.

About This Community

This platform is for beginners and experts willing to share their Odoo knowledge. It's not a forum to discuss ideas, but a knowledge base of questions and their answers.

Register

Odoo Training Center

Access to our E-learning platform and experience all Odoo Apps through learning videos, exercises and Quizz.

Test it now

Question tools

1 follower(s)

Stats

Asked: 11/4/16, 11:30 AM
Seen: 337 times
Last updated: 9/14/17, 5:13 AM