Odoo Help


This community is for beginners and experts willing to share their Odoo knowledge. It's not a forum to discuss ideas, but a knowledge base of questions and their answers.


could not restore the database openerp

on 7/21/14, 11:11 AM 9,240 views

When I try to restored the backup database using "Database Manager" it shows error like this "Could not restore the database", So can anyone help me? I'm using OpenERP v8.
Thank You.

Hello Madura. Did the backup came from a different installation than the one where you tried to restore the backup? If yes, can you pleas check what is the version referenced when you click "About" under your user name in the upper right corner for both installations?

George Rodopoulos
on 8/22/14, 11:39 AM
Amol Gangajaliwale
On 12/12/14, 2:37 AM


I think your database size has gone big . Try these commands in terminal

For Restore   DB=new_database_name && createdb $DB && psql -d $DB < backup_database

For Backup   pg_dump --cluster 9.1/main --format=c old_database_name > new_database_name



I just had the same issue, and it was, at least in my case, something very silly: I restored the database a second time, with the same name. The only thing is that after the first time, the information was not updated, that is, the new database didn't appear in other options, like the Drop, or the duplicate functionality. Only when I hit Refresh and went back to login, I could see the new DB in the list of options.



| 5 2 6
Lomé, Togo


On 7/21/14, 12:04 PM

Hi Madura,

I see you use the tag openerp7; so if you try to restore V7 database in V8 you will get this error.

Or if you try to restaure openerp8 database in odoo8 you'll get thus the same error.


Hi Koffi KPONOUGLO, Thank You for the help. as you told , The backup database I have which is from OpenERP v8 and planning to restore it in Odoo8, So any other way to do this ? Thank You.

on 7/21/14, 11:38 PM

@Madura: OpenERP v8 and Odoo v8 is the same thing. Which exactly branch from github is used for the installation where the backup came from? Which exactly branch from github is used for the installation where the backup will be restored ?

George Rodopoulos
on 8/22/14, 5:40 AM

@Rodopoulos : OpenERP V8 and Odoo v8 are not the same thing. Database structure is not the same.

on 8/22/14, 8:23 AM

@Koffi: That seems strange to me. I thought that after the previous version of OpenERP V7, OpenERP V8 would normally come out but in the meanwhile OpenERP was renamed to Odoo. So, I thought that OpenERP V8 is actually Odoo V8 which currently has status RC1 and can be found here: https://github.com/odoo/odoo/tree/8.0 . If what you say is true, where can I find the code for OpenERP V8 and what are the differences that cause a different database structure?

George Rodopoulos
on 8/22/14, 8:36 AM

@Rodopoulos : It is not strange it is normal. We are not talking about name OpenERP or name Odoo. We are talking about their database structure. I could say odoo v8 is a "new realise of openerp v8". all actual link i could propose you are updated so i can't give you a good link but if you want give me your email i can send you openerp8 et odoo 8 source code and you wil try to restore bdd between.

on 8/22/14, 9:26 AM

@Koffi:OpenERP V7 existed but I've never heard of OpenERP V8. Where did you find it ? If it is not available now, when was it and where (if you have even a broken link, please send it) ? Do you currently have a running installation of OpenERP V8 ? If yes, what is the version mentioned when you click about.

George Rodopoulos
on 8/22/14, 9:43 AM

@Rodopoulos : Yes i have a running installation of OpenERP Version 8.0dev-20140416-230101. Search on the forum you will see i right. I have the code i am ok to send it to you.

on 8/22/14, 9:55 AM

@Koffi: Thanks for the info. I finally found Version 8.0dev-20140416-230101 among other nightly builds of trunk here: http://nightly.openerp.com/trunk/nightly/src/ I think that this version is actually an Odoo V8 nightly build when it was still at dev status Alpha and just before changing references from OpenERP to Odoo. You can see the /openerp/release.py file at about that point of history in github here: https://github.com/odoo/odoo/blob/b2fc19045b5a4e337c62757679dd9761043badb8/openerp/release.py#L37 So, ok, the difference is not the name as you said too. The difference is the actual version/build/development status of the two installations.

George Rodopoulos
on 8/22/14, 11:28 AM

Ben Bernard

--Ben Bernard--
| 4 3 6
Jakarta, Indonesia
--Ben Bernard--
Ben Bernard
On 7/21/14, 11:34 AM

I have similar problem with OpenERP 6.1. I don't know the problem. But when I want to restore database, I use postgresql client, like pgAdmin III, which is quite straight forward. Sometimes database dump in binary is also problematic, in this case I re-dump the database in SQL and then restore it.

Hi Ben Bernard, Thankx for the help, the way you tried, was it worked sucessfully?

on 7/21/14, 11:41 PM

Your Answer

Please try to give a substantial answer. If you wanted to comment on the question or answer, just use the commenting tool. Please remember that you can always revise your answers - no need to answer the same question twice. Also, please don't forget to vote - it really helps to select the best questions and answers!

About This Community

This community is for professionals and enthusiasts of our products and services. Read Guidelines

Question tools

2 follower(s)


Asked: 7/21/14, 11:11 AM
Seen: 9240 times
Last updated: 3/16/15, 8:10 AM