Odoo Help


This community is for beginners and experts willing to share their Odoo knowledge. It's not a forum to discuss ideas, but a knowledge base of questions and their answers.


Company informations not accurate on POS receipt

Victor Godayer
on 11/22/13, 12:14 PM 1,179 views


I'm using the module POS, and I struggle to make my company informations accurate on the purchase receipt.

I did set my company information in "Settings -> General Settings -> Configure your company data", but the purchase receipt keep displaying "Your company".




Thierry Godin

--Thierry Godin--
| 8 7 8
Collegien, France
--Thierry Godin--


Thierry Godin
On 11/24/13, 3:41 AM


This is because the user (you) is using POS of administrator wich company is "My Company" by default.

Be sure the user is assigned to the company you set:

Go to Configuration -> Users - > Click on the user -> Modify ->Go to Access rights tab -> Authorized companies

The company you set must be displayed here.

Be sure the POS is assigned to the user :

Go to Configuration -> Users - > Click on the user -> Modify -> Go to Point of sale tab

Select the POS you set . If you do not set any POS for this user, user uses default POS wich is assigned to default company (ie "My Company")


Thanks Thierry for your help. I went to Configuration -> Users - > Click on the user -> Modify ->Go to Access rights tab, but I didn't see any "Authorized Companies" (I set the language to english)

Victor Godayer
on 11/25/13, 4:41 AM

Ok, I turned to English (I'm french) and the right sentence is "Allowed Companies"

Thierry Godin
on 11/25/13, 5:44 AM

I still do not see this label on the tab..I see the company to which the user is attached on the top of the tabs but that's it! I'm using openerp v7 to recall the context i fit can help

Victor Godayer
on 11/25/13, 6:41 AM

Oh, I see, maybe this is because I enabled Multi Company. Sorry, but I don't know how-to help more.

Thierry Godin
on 11/25/13, 7:53 AM

Ok I set to multi-company, double checked that the users were associated to the apropriate company, and edited a new "Default Company per Object" with the object Account, and still see "Your company" on the purchase receipt...

Victor Godayer
on 11/25/13, 9:17 AM

Ok I found something that could help. When I go to my profile preferences (top right corner of the screen) the window opens and I can only see the label 'Default point of sale', but it should show as well 'Company' label with a drop-down list to chosse the company of the user. Do you have any idea I don't see this label + drop-down box ?

Victor Godayer
on 11/25/13, 9:35 AM

Your Answer

Please try to give a substantial answer. If you wanted to comment on the question or answer, just use the commenting tool. Please remember that you can always revise your answers - no need to answer the same question twice. Also, please don't forget to vote - it really helps to select the best questions and answers!

About This Community

This community is for professionals and enthusiasts of our products and services. Read Guidelines

Question tools

0 follower(s)


Asked: 11/22/13, 12:14 PM
Seen: 1179 times
Last updated: 3/16/15, 8:10 AM