Odoo Help

Welcome!

This community is for beginners and experts willing to share their Odoo knowledge. It's not a forum to discuss ideas, but a knowledge base of questions and their answers.

0

[Closed] Why am I unable to connect to database server on a new installation?

By
Zanga Chimombo
on 8/11/13, 8:35 AM 1,346 views

I have installed openerp-server and openerp-client on debian using apt-get install. However, when I launch the client I get the following error "Could not connect to server" in the log-in box on the database line.

I've checked the .openerprc config file but don't know what I should be looking for.

The server seems fine. The following is the output of tail -f /var/log/openerp-server.log [2013-08-11 11:01:23,843] INFO:shutdown:Shutdown Server! - SIGTERM [2013-08-11 11:09:56,453] INFO:server:version - 5.0.12 [2013-08-11 11:09:56,454] INFO:server:addons_path - /usr/share/pyshared/openerp-server/addons [2013-08-11 11:09:56,454] INFO:server:database hostname - localhost [2013-08-11 11:09:56,454] INFO:server:database port - 5432 [2013-08-11 11:09:56,454] INFO:server:database user - openerp [2013-08-11 11:09:56,454] INFO:objects:initialising distributed objects services [2013-08-11 11:09:56,619] INFO:web-services:starting XML-RPC services, port 8069 [2013-08-11 11:09:56,619] INFO:web-services:starting NET-RPC service, port 8070 [2013-08-11 11:09:56,619] INFO:web-services:the server is running, waiting for connections...

The fact that my attempt to connect using the client is not showing up in the server logs is worrying! Neither does an attempt to browse to the web client using the localhost 8069 port

Help please!

Zanga.

0
Xsias
On 8/12/13, 6:56 AM

You must not use the XML-RPC services port, do a search in your configuration files for HTTP service (werkzeug) port.

ok. i don't think I have installed Apache yet, so I cannot expect the web client to work. however, the local client (apt-get install openerp-client) should not require Apache, should it?

Zanga Chimombo
on 8/13/13, 2:52 AM

I am also seeing here: http://www.its1.lv/en/home-en/15-blog/63-how-to-set-up-openerp-on-debian-sever that I may require postgresql 9.1, not 8.4 that I have...

Zanga Chimombo
on 8/13/13, 2:53 AM

So, have you upgrade you postgresql ? Does it work ?

Xsias
on 8/13/13, 9:51 AM

yeah! the link i posted really helped. i only followed the instructions down to SET UP BAZAAR because i haven't set up web server yet. but i can now use openerp using non web client! many thanks!!!

Zanga Chimombo
on 8/13/13, 9:10 PM

My pleasure. You can close your question with an [Closed] in the title.

Xsias
on 8/14/13, 8:18 AM

Your Answer

Please try to give a substantial answer. If you wanted to comment on the question or answer, just use the commenting tool. Please remember that you can always revise your answers - no need to answer the same question twice. Also, please don't forget to vote - it really helps to select the best questions and answers!

About This Community

This community is for professionals and enthusiasts of our products and services. Read Guidelines

Question tools

1 follower(s)

Stats

Asked: 8/11/13, 8:35 AM
Seen: 1346 times
Last updated: 3/16/15, 8:10 AM