Odoo Help

1

Changing xmlrpc_port from 8069 to 8070 causes report issues?

By
om
on 8/21/14, 9:30 AM 1,426 views

Hi all,

I have followed the suggestions on changing the odoo deafault port in this thread:

https://www.odoo.com/forum/help-1/question/how-to-change-the-default-port-8069-used-by-odoo-server-60679

After changing the config file and reloading odoo it loads fine on port 8070 and every seems ok, however when I print any kind of report (invoices, qoutes, etc) they do not have headers or footers. When changing the port back all prints normally. What am I missing?

Thanks alot.

Can you please try also another port different than 8070. Just to make sure that it doesn't have anything to do with the specific port.

George Rodopoulos
on 8/21/14, 9:34 AM

Hi George, I tried on about 4 different ports (8095; 9191 were two of them). The result is the same, everything loads fine and on the specified port but the reports are missing headers and footers. When switched back to 8069, headers and footers are back. Thanks.

om
on 8/21/14, 10:49 AM
1
om
On 8/25/14, 2:47 PM

Found the answer to the question here : https://github.com/odoo/odoo/issues/1105

It was as simple as changing the sysem parameter web.base.url to the correct ip and port.

About This Community

This platform is for beginners and experts willing to share their Odoo knowledge. It's not a forum to discuss ideas, but a knowledge base of questions and their answers.

Register

Odoo Training Center

Access to our E-learning platform and experience all Odoo Apps through learning videos, exercises and Quizz.

Test it now

Question tools

1 follower(s)

Stats

Asked: 8/21/14, 9:30 AM
Seen: 1426 times
Last updated: 3/16/15, 8:10 AM