Odoo Help


This community is for beginners and experts willing to share their Odoo knowledge. It's not a forum to discuss ideas, but a knowledge base of questions and their answers.


Changing xmlrpc_port from 8069 to 8070 causes report issues?

on 8/21/14, 9:30 AM 1,217 views

Hi all,

I have followed the suggestions on changing the odoo deafault port in this thread:


After changing the config file and reloading odoo it loads fine on port 8070 and every seems ok, however when I print any kind of report (invoices, qoutes, etc) they do not have headers or footers. When changing the port back all prints normally. What am I missing?

Thanks alot.

Can you please try also another port different than 8070. Just to make sure that it doesn't have anything to do with the specific port.

George Rodopoulos
on 8/21/14, 9:34 AM

Hi George, I tried on about 4 different ports (8095; 9191 were two of them). The result is the same, everything loads fine and on the specified port but the reports are missing headers and footers. When switched back to 8069, headers and footers are back. Thanks.

on 8/21/14, 10:49 AM
On 8/25/14, 2:47 PM

Found the answer to the question here : https://github.com/odoo/odoo/issues/1105

It was as simple as changing the sysem parameter web.base.url to the correct ip and port.

Your Answer

Please try to give a substantial answer. If you wanted to comment on the question or answer, just use the commenting tool. Please remember that you can always revise your answers - no need to answer the same question twice. Also, please don't forget to vote - it really helps to select the best questions and answers!

About This Community

This community is for professionals and enthusiasts of our products and services. Read Guidelines

Question tools

1 follower(s)


Asked: 8/21/14, 9:30 AM
Seen: 1217 times
Last updated: 3/16/15, 8:10 AM