Odoo Help


Changing currency in Open ERP [Closed]

Pranav Ashtaputre
on 4/5/13, 5:19 PM 24,613 views

The Question has been closed

Ray Carnes
on 11/05/2013 17:53:31

Hi, I am not able to change currency in Purchase settings. Even when I create new currency($), it does not change in the existing purchase orders. Kindly suggest a solution.

Thanks Pranav


Ray Carnes

--Ray Carnes--
| 9 7 9
Keyport, United States
--Ray Carnes--

Senior ERP Analyst

OpenERP 6.1, 7.0; Odoo 8.0, 9.0, 10.0 and 11.0.

Completed Odoo Functional and Technical Training.

Functional Areas:

  • CRM/Sales

  • Inventory

  • Manufacturing

  • Accounting

  • Purchasing

Major Skills:

  • Business Process Reengineering

  • Efficiency Consulting

  • User Needs and GAP Analysis;

  • Functional and Technical Design;

  • Prototyping and Proof of Concepts;

  • Requirements Specifications;

  • Agile Implementation;

  • Data Migration;

  • Configuration & Customization (UI and code);

  • Integration - Odoo and non Odoo Applications and Services;

  • Training and Knowledge Transfer;

  • Go Live Support;

  • Helpdesk;

  • Version Upgrades and Migration.

  • Accounting Expert.

I have over 20 years of experience empowering and enabling users with enterprise information systems that make a real and measurable difference in their ability to proactively manage their businesses and organizations. 

I am a skilled Communicator and I only take the serious things seriously!

Ray Carnes
On 4/5/13, 9:33 PM

Navigate to Settings -> Configuration -> Accounting

Change the value for Default Company Currency

image description

Next, Nagivate to Settings -> Configuration -> Purchases

Check Manage Pricelist by Supplier

image description

Next, Navigate to Settings -> Configuration -> Sales

Check Use pricelists to adapt your price per customers

image description

Finally, navigate to Purchases -> Configuration -> Pricelists

Clear the search filter 'Pricelist Type':

image description

You can then select both pricelists and, from the Move menu, and export them.

Choose the blue fields, so you can re-import them (after you change the currency).

image description

Open the CSV file and change both currency_id/id values to base.USD or base.AUD or base.CAD (or the ISO code of the currency you are changing to - see http://www.xe.com/iso4217.php for a list).

Save the CSV file and import it (again from the More meny) to update the pricelists.

OpenERP won't go back and change historic documents. You need to cancel and re-create any Purchase Orders that are wrong.

Uncheck Check Manage Pricelist by Supplier and Check Use pricelists to adapt your price per customers if you don't want pricelists exposed.

I have done exactly till the last step. I exported the file and changed EUR to INR and saved the file on my machine. But from the "More" menu I don't find any import option where I can save the data back. I don't have any import option.

Srinivas Reddy
on 7/29/13, 2:42 PM

Import is not under the "More" menu. It is next to the CREATE button when the LIST view is active. If you can't see it, make sure "Allow users to import data from CSV files" is checked on Settings --> Configuration --> General Settings.

Ray Carnes
on 7/29/13, 2:47 PM

It works. Thanks

on 12/27/15, 1:42 PM
On 11/5/13, 5:20 PM

it works than you

About This Community

This platform is for beginners and experts willing to share their Odoo knowledge. It's not a forum to discuss ideas, but a knowledge base of questions and their answers.


Odoo Training Center

Access to our E-learning platform and experience all Odoo Apps through learning videos, exercises and Quizz.

Test it now

Question tools

5 follower(s)


Asked: 4/5/13, 5:19 PM
Seen: 24613 times
Last updated: 5/9/17, 11:20 AM