Odoo Help

4

2
4 Answers
6
Avatar

ClueLogics Technologies Pvt. Ltd. India

--ClueLogics Technologies Pvt. Ltd.--
6223
| 7 5 10
Delhi NCR, India
--ClueLogics Technologies Pvt. Ltd.--

 ClueLogics Technologies Pvt Ltd is a Software product and services provider. We are positioned to deliver robust, rapid and reliable Information Technology solutions that work. What we succeed upon is Technology and Technical Expertise. The industry review of ClueLogics has been commendable for the past years as most of its business comes from repeat orders by highly satisfied clients.

ClueLogics Technologies Pvt. Ltd. India
5/7/13, 8:23 AM

Hi Mr. Nathan ,

did you change login field value , plz be that "admin"

it might be used in domin (for security) for various model (object)

just change value of User field

then there will no be any effect for access

5 Comments
Nathan Netherlands
5/7/13, 8:26 AM

Yes, I changed the login field value in the user settings. How can I change the value of the "User field", where can I find this?

ClueLogics Technologies Pvt. Ltd. India
5/7/13, 8:27 AM

just let it be same (admin) just change the user field value for display purpose, "admin" might be used in access right rule , that why you can't see all the accessibility

Nathan Netherlands
5/7/13, 8:28 AM

problem is that I can't change any user settings anymore........

ClueLogics Technologies Pvt. Ltd. India
5/7/13, 8:30 AM

you can change,, just change name according to you , don't change login

Nathan Netherlands
5/7/13, 9:26 AM

that's my problem, I can't change any user settings anymore, the "users" menu has disappeared since changing the username.

0
Noor Nepal
1/4/15, 11:45 PM

Hi Nathan,

Were you able to find a solutions to your problem, I have a same problem

0
Viet Nguyen Australia
5/26/13, 10:01 PM
  1. Log into your PostgresSQL database
  2. Run this to find the User ID of your admin user: select id,login from res_users;
  3. Run this to give you access back to the settings: Insert into res_groups_users_rel values (the_id_found_in_step_2, 2);

Hope it helps.

Viet

0
Avatar

Martin Canada

--Martin--

2068
| 6 6 10
Cornwall, Canada
--Martin--

Analysing, designing, coding and mentoring since 1975. Kilobytes to terabytes. Punch cards to punchy sites. My OpenERP video series: http://www.youtube.com/playlist?list=PLq7op4J183lX44ZlXPiHxUpRvmmRDtxye My Google Speadsheets --> OpenERP Data Pump project: http://martinhbramwell.github.io/GData_OpenERP_Data_Pump My email (with spaces removed) : mhb . warehouseman @ gmail . com

Martin Canada
5/7/13, 9:57 AM

I suspect your only hope is to edit the database. :-(

Although it answers a different question, you might learn how you can do that from this post : https://accounts.openerp.com/forum/Help-1/question/478#487

Your problem, I think, is that the label admin has special significance in OpenERP, just like root has special significance in Unix systems. If you want to always use a different UID, (as is considered best practice in most operating systems), you need to create a new user for that, and give as many privileges as possible to that user.

Even then, that user may have some limitations.

1 Comment
Nathan Netherlands
5/7/13, 10:21 AM

thanks, I've edited res_users in the database and changed user with ID "1" back to "admin", unfortunately after logging in I still can't see all the menu's in "Settings". Do I need to change anything else?

Ask a Question
Writer
Keep Informed
0 follower(s)
About This Community

This platform is for beginners and experts willing to share their Odoo knowledge. It's not a forum to discuss ideas, but a knowledge base of questions and their answers.

Register
Odoo Training Center

Access to our E-learning platform and experience all Odoo Apps through learning videos, exercises and Quizz.

Test it now