Odoo Help

0

change font in header

By
Aeneas Winterhalter
on 7/23/13, 11:31 PM 1,824 views

I try to change the font in the header/footer with a custom one. so i copied my linotype.ttf font to: /usr/share/fonts/truetype/linotype/linotype.ttf

then i run "fc-cache -fv" and "fc-cache -f -v"

After that i edited the /opt/openerp/server/openerp/report/render/rml2pdf/customfonts.py and added ('linotype','linotype','linotype.ttf','all') at the CustomTTFonts list.

Nothing... still same old font.

Then i tried an other font listed in /opt/openerp/server/openerp/report/render/rml2pdf/customfonts.py. didn't work either... wierd.

any ideas?

code looks terrible here.... RML Header in comment.

Text of RML header here: http://tny.cz/961c9273

Aeneas Winterhalter
on 7/23/13, 11:37 PM

I had a similar problem. For reasons I did not further investigate, there were a few other versions of customfonts.py in different locations on my system. Maybe something went wrong during the installation. It seems like openERP uses one of them instead.

Try searching your system for other versions of the file, edit them and see if it changes anything. I had to restart the server process between trials to see change.

Jörn Tomaszewski
on 8/8/13, 1:13 PM

About This Community

This platform is for beginners and experts willing to share their Odoo knowledge. It's not a forum to discuss ideas, but a knowledge base of questions and their answers.

Register

Odoo Training Center

Access to our E-learning platform and experience all Odoo Apps through learning videos, exercises and Quizz.

Test it now

Question tools

1 follower(s)

Stats

Asked: 7/23/13, 11:31 PM
Seen: 1824 times
Last updated: 3/16/15, 8:10 AM