Odoo Help

Welcome!

This community is for beginners and experts willing to share their Odoo knowledge. It's not a forum to discuss ideas, but a knowledge base of questions and their answers.

0

Cant access Open ERP Vs7 on Local Network?

By
Samson Olawale Sholademi
on 1/2/14, 10:09 AM 8,731 views

Hello Guys,

I just completed an installation of Open ERP Vs7 on a Window 2008 Server R2 Standard Edition.

The Open ERP server can be accessed on the local host and remotely and also on mobile devices over the internet using my Network static(public) IP address with the port 8069, but computers and laptops within the local Network cant not!

I have deactivated the firewalls on the server and still cant get access.

Kindly assist me.

When you try to access the OpenERP server from within the LAN, are you using the Public IP address or the internal IP address of the server. It is good that you checked the firewall but there must be some other networking issue.

Rich Granata
on 1/2/14, 10:30 AM

For remote access you forwarded port 8069 through your router to the static IP Address of the Win2k8 server. When you try to access from the LAN are you using the same IP Address as your router has port forwarded? Using the same LAN PC that fails can you access OpenERP through your public IP Address or does your security architecture disable round-tripping?

Moore Works, Dale E. Moore
on 1/4/14, 5:56 PM
0
David Jorge
On 1/4/14, 5:37 PM

Maybe Firewall?

0
Mehdi
On 8/8/14, 4:05 AM

try the last command lines of this post in order to enable access to your openERP application.

 

https://www.odoo.com/forum/help-1/question/install-openerp-7-on-red-hat-17005

Hope it could help. ;)

 

0
Eric
On 1/2/14, 5:58 PM

First you need to get the internal ip address from the computer that has openerp installed on it. Then the other computers can type in that ip address and append a :8069 to the end of it in their web browsers. That should be able to allow other internal computers to access it.

Step 1: Go to the computer with OpenERP installed, click on "Start" and type in cmd into the search bar below

Step 2: Click on cmd.exe

Step 3: Type in "ipconfig" and write down the internal ip address ex: 192.168.1.1

Step 4: Go to another computer and open a web browser

Step 5: Type in the ip address with a :8069 into the url bar of the web browser ex: 192.168.1.1:8069

Hope this helped

0
Andy
On 1/5/14, 8:04 PM

Hallo.. this is easy to resolve.

This with the external IP do-sent work on all Routers. just some router are able to reroute a request from internal network to the external IP address back.

To fix up. first check your external URL Host entry for your external IP: add a Host entry on your external DNS Server. eg: erp.mycompany.com --> externeal-IP

Put this external Host adress inside your ERP under parameter/systzem parameter/web_base_URL after this your ERP scholt by work from external.

for internal. Create on your Domain Server AD-DNS new Master zone with the same Dmain name as your external Domain name. ther you have entered in (web_base_url).

Create a reverse zone on your network Subnet range. eg: 192.168.10.x Now add host name to your DNS master zone erp with the internal IP address.

new boot DNS converting the name erp.mycompay.com on internal network to internal ip ore from external to the external IP address. Openerp tells every time the base URL to the Browser for all links.

Yust make sure in your DHCP server is the primary DNS server the internal DNS-Server as primary set. The internal Clients most resolve the IP address from Internal DNS Server.

Your Answer

Please try to give a substantial answer. If you wanted to comment on the question or answer, just use the commenting tool. Please remember that you can always revise your answers - no need to answer the same question twice. Also, please don't forget to vote - it really helps to select the best questions and answers!

About This Community

This community is for professionals and enthusiasts of our products and services. Read Guidelines

Question tools

1 follower(s)

Stats

Asked: 1/2/14, 10:09 AM
Seen: 8731 times
Last updated: 3/16/15, 8:10 AM