Odoo Help


This community is for beginners and experts willing to share their Odoo knowledge. It's not a forum to discuss ideas, but a knowledge base of questions and their answers.


Cannot sign up with google account (oauth)

on 4/3/13, 1:46 PM 3,357 views

I'm trying to set up oauth.

After an attempted log in, I get redirected to:


If I look at


it doesn't cater for this code.

What does it mean?



| 5 6 8
Cornwall, Canada

Analysing, designing, coding and mentoring since 1975. Kilobytes to terabytes. Punch cards to punchy sites. My OpenERP video series: http://www.youtube.com/playlist?list=PLq7op4J183lX44ZlXPiHxUpRvmmRDtxye My Google Speadsheets --> OpenERP Data Pump project: http://martinhbramwell.github.io/GData_OpenERP_Data_Pump My email (with spaces removed) : mhb . warehouseman @ gmail . com

On 4/16/13, 1:39 PM

I saw you ask this originally a couple of weeks ago. I tried to replicate the problem, but couldn't. However, having gone through the whole process successfully I made some videos. I'd be pleased to know that they got you past this road-block.

They don't address your oauth_error=3 problem, but if you were to try the same steps as in the video on a fresh database and were successful, it might help you understand what when wrong to cause the error in the first place.

OpenERP and Google

All three together will cost you 7 minutes. :-)

(no audio by choice)

Have watched them - they're great, thank you. But yes, doesn't help. I can't even sign up, so don't get anywhere. I'm starting to suspect its an setting on my google app domain regarding federated sign in, but can't find the issue.

on 4/16/13, 1:47 PM

Hmmm. I remember seeing something on the web about OAuth being different for Google Apps accounts and normal free personal accounts. Have you tried creating a new "plainold" GMail account, and testing everything with that?

on 4/16/13, 1:53 PM

Have you even detected which software throws oauth_error=3, to get an idea of what it is supposed to mean? Anything in your log files?

on 4/16/13, 1:56 PM

@Martin H. Bramwell: so you've taken all this time to look into somebody else's problem, and recorded videos and all. That's what open source should be about, great work! At least they should honor you with a special badge, "dedicated" or something similar.

Lorenzo Cabrini
on 4/16/13, 9:42 PM

I wouldn't take it to that extreme. In fact open source is about sharing the benefits of one's own research. Thenon's problem coincided with my own need, and I wanted to be sure I knew how to avoid the oauth_error=3 sinkhole. I also saw a real lack of a proper explanation on how to do Google OAuth, so I made the videos. I tried to make the kind of howto video I myself look for : a thorough explanation in less than 10 minutes. Sure, a special badge would be nice! Of course getting your one up tick of recognition is also nice. Thanks! Well, I got one anyway. :-(

on 4/16/13, 10:01 PM

Agreed - thanks for the help! Well this is the error the debug log shows: openerp.addons.auth_oauth.controllers.main: OAuth2: access denied, redirect to main page in case a valid session exists, without setting cookies. Haven't tried plain ol gmail yet (agree its a good idea) because to be honest, if I can't get it working for the apps domain, then it's not useful to me.

on 4/17/13, 1:37 PM

I do not have an apps domain or I would try it out, to see if it is indeed the case that there are differences. Perhaps someone else can confirm. I don't have time right now.

on 4/17/13, 2:26 PM

hey, I suppose you have tried from a different browser?

on 4/17/13, 2:44 PM
Cody Unrath
On 10/18/14, 5:06 PM

I'm having a similar issue but I'm only getting the 500 internal server error, but, the user ends up in Odoo anyway.


My issue was due to the default template for external user sign-in being set to Public user:

Settings --> General Settings:

 □ Allow external users to sign up

Template user for new users created through signup [Public user] □->

I read about this in a Bug report, Public user does not have the proper permissions and is not reccomended for use in this instance.


500: Internal server Error After New Public User Signup/Login #951

David Dean
On 10/19/14, 8:36 AM

Here are detailed instructions on how I managed to get Google Apps (not Gmail) authentication to work with Odoo 8:


Google Apps authentication is different to standalone Gmail accounts, so make sure you follow each step carefully. In particular, filling out the consent screen section is important otherwise your redirect won't work. Most instructions don't mention this bit.


Your Answer

Please try to give a substantial answer. If you wanted to comment on the question or answer, just use the commenting tool. Please remember that you can always revise your answers - no need to answer the same question twice. Also, please don't forget to vote - it really helps to select the best questions and answers!

About This Community

This community is for professionals and enthusiasts of our products and services. Read Guidelines

Question tools

1 follower(s)


Asked: 4/3/13, 1:46 PM
Seen: 3357 times
Last updated: 3/16/15, 8:10 AM