Odoo Help

Welcome!

This community is for beginners and experts willing to share their Odoo knowledge. It's not a forum to discuss ideas, but a knowledge base of questions and their answers.

0

Cannot send email out using own smtp

By
Jessie
on 5/29/13, 7:39 AM 16,693 views

Hi all,

I have installed openerp-allinone-setup-7.0-latest in windows server 2008 R2.

I have configured the outgoing email servers and Test Connection. The message “Connection test succeeded! Everything seems properly set up!” but I failed to send out an email. May I know what is the problem?

Should I modify the configuration in openerp-server.conf as below?

specify the SMTP email address for sending email

email_from = False

specify the SMTP server for sending email

smtp_server = localhost

specify the SMTP port

smtp_port = 25

specify the SMTP server support SSL or not

smtp_ssl = False

specify the SMTP username for sending email

smtp_user = False

specify the SMTP password for sending email

smtp_password = False

Many thanks.

@ Jessie Goto Settings--> General Settings --> Configure the Outgoing Email Server --> create new--> Description: Gmail, smtp server: smtp.gmail.com, Smtp port: 465, Debugging marked, connection security: SSL/TLS, Gmail username, password, now click Test connection, result is Connection test succeeded! Everything seems properly set up! . check it.

sridhar
on 5/29/13, 8:35 AM

I have done this all, but still not able to go ahead, please suggest something else. I am able to see all the sent mail details in LOGS.

Vaibhav
on 9/6/13, 8:58 AM
3
Christian Twinckle
On 5/29/13, 10:22 AM

In setting > technical > email > outgoing mail server :

try to configure it with :

Smtp server: smtp.gmail.com

Smtp port: 465

Connection Security: SSL/TLS

Enable debugging mode and provide your username: user@gmail.com and password.

Now save it and click Test connection.

Result: Connection test succeeded!Everything seems properly set up!

Now go to Messaging menu in and click on Compose a new message and send a message.

Hope this works :) .

Regards,

1
Justin Kintzele
On 7/29/13, 6:34 PM

I was able to get past this error by populating the "Email" field in the company information for the company I have setup. Just mouse over the company icon in the upper-left hand side and click "Edit Company data". When the company information form appears fill in an email address on the right hand side of the form. This email address field is used for the sending address when creating a new user. When creating a new user before this information has been populated a misleading error is displayed on the page that "Cannot send email: No outbound email servers are defined...", but this is not accurate. This error is displayed even when outbound SMTP servers have been configured. A full write-up of this can be found under bug 1160819.

Thank you very much!

Sascha Pfeiffer
on 9/10/15, 3:28 AM
0
sridhar
On 5/29/13, 8:32 AM

@ Jessie Goto Settings--> General Settings --> Configure the Outgoing Email Server --> create new--> Description: Gmail, smtp server: smtp.gmail.com, Smtp port: 465, Debugging marked, connection security: SSL/TLS, Gmail username, password, now click Test connection, result is Connection test succeeded! Everything seems properly set up! . check it.

-1
Ahmed elbarbary
On 10/12/14, 7:40 AM

did any one find the solution of that error ? i face same problem 

-1
Jessie
On 5/30/13, 1:51 AM

Hi,

Thanks for help.

I successfully send an email out if compose a new message but I cannot send an invitation email (Users -> Send an invitation email). The error message is as below although i already configure the outgoing email.

Cannot send email: no outgoing email server configured. You can configure it under Settings/General Settings.

Thanks.

Regards, Jessie

I am having this same problem. When I go to "General Settings" the "Configure outgoing email servers" link takes me to where I have already setup the outgoing servers, and have testing the connection successfully... But when I go to send a new user an invitation I get the same error that Jessie is getting. I do not see where else to configure/select the outgoing email server that I have defined for this company.

Justin Kintzele
on 5/30/13, 1:56 PM

I am facing same issue. unable to invite but am able to send messages... Please suggest..

paras
on 7/26/13, 11:08 AM

Even I am facing the same problem. Connection Test succeeds when configuring SMTP (I did it with Amazon SES SMTP and then saved it), but when I try to add a user it says that no Outgoing SMTP Server is configured.

P Mittal
on 7/28/13, 8:58 AM

You must populate the "Email" field in the company information form for the company you have setup in your system. The error message is misleading and should be more specific. What it should say is "There is no email address to use for the 'From:' address, please update the Email address information for your company."

Justin Kintzele
on 8/8/13, 3:09 PM

I did populate the Email field for my company but I'm still getting that misleading error, even I tested successsfully the configuration of the outgoing mail. Anyone's got another clue that can help on the case? Thanx

Serge Segbefia
on 3/27/14, 8:17 PM

I did populate the Email field for my company but I'm still getting that misleading error, even I tested successsfully the configuration of the outgoing mail. Anyone's got another clue that can help on the case? Thanx

Serge Segbefia
on 3/27/14, 8:24 PM

did any one find the solution for this issue ? i face the same problem and i didn't find how to fix it .

Ahmed elbarbary
on 10/26/14, 4:08 AM

Your Answer

Please try to give a substantial answer. If you wanted to comment on the question or answer, just use the commenting tool. Please remember that you can always revise your answers - no need to answer the same question twice. Also, please don't forget to vote - it really helps to select the best questions and answers!

About This Community

This community is for professionals and enthusiasts of our products and services. Read Guidelines

Question tools

2 follower(s)

Stats

Asked: 5/29/13, 7:39 AM
Seen: 16693 times
Last updated: 3/16/15, 8:10 AM