Odoo Help

Welcome!

This community is for beginners and experts willing to share their Odoo knowledge. It's not a forum to discuss ideas, but a knowledge base of questions and their answers.

1

cannot send email from other SMTP providers ..only gmail

By
Joshua Levy
on 3/24/13, 10:13 PM 13,624 views

Hi,

I am very new to the OpenERP 7 and liking it a lot. However, I only send emails from gmail SMTP servers, configured as outgoing server.

However any other SMTP servers dont work !!

for instance, one.com :- the SMTP settings are send.one.com with SSL/2525 port settings.

If I configure these settings within OpenERP 7 I get the following error


Connection test failed!

Here is what we got instead: 1 _ssl.c:480: error:140770FC:SSL routines:SSL23_GET_SERVER_HELLO:unknown protocol


If I select any other security protocol like TLS or non it says connection succeeded. However no emails are sent.

Please help

Many thanks

Joshua

Hi Karim,

When I change the port from 2525 to 25 and select SSL/TLS, I get the following error:

Connection test failed!

Here is what we got instead: 10060 A connection attempt failed because the connected party did not properly respond after a period of time, or established connection failed because connected host has failed to respond

Ok

I would really appreciate some help..

Many thanks

Joshua

Joshua Levy
on 3/25/13, 4:29 AM

Why the mails are not sended? some info on logs?

Juanjo Algaz
on 6/5/13, 1:57 PM
0
my
On 12/14/14, 11:42 PM

hi.

i have the same problem. my smtp is send.one.com. one.com have no smtp.one.com. thats bad because i can`t send email with openerp/odoo. but my second domain (by an aother hoseter who have smtp.mydomain.de) i can send emails by odoo. I think that my problem is the send.one.com. i don`t find how to fix the problem.

i have openerp7 on windows7 64 bit. perhaps is here someone who can help me please?

thanks

0

IBS

--IBS--
1302
| 4 5 8
Tétouan, Morocco
--IBS--

For more informations about IBS, please visit our website at www.ibs-na.com.

For a specific questions, collaboration or help, please send us an email to support@ibs-na.com

IBS
On 3/24/13, 10:38 PM

Try keeping the same port number 465 that OpenERP suggested or port 25 and select SSL/TLS From the Connection Security drop down list.

Hi Karim,

When I change the port from 2525 to 25 and select SSL/TLS, I get the following error:

Connection test failed!

Here is what we got instead: 10060 A connection attempt failed because the connected party did not properly respond after a period of time, or established connection failed because connected host has failed to respond

Ok

I would really appreciate some help..

Many thanks

Joshua

Joshua Levy
on 3/25/13, 4:26 AM

Did you try port 465?

IBS
on 3/25/13, 6:04 AM

Hi Yes Karim, I did...same result !!

Joshua Levy
on 3/25/13, 6:11 AM

Just go with TLS ( Use port 2525 ) because that works for you, after that try to compose an email ( top right corner ) and send it to an email of yours.

IBS
on 3/25/13, 6:45 AM

Hi Karim, I did that many times... no emails sent !

Joshua Levy
on 3/25/13, 6:46 AM

Go to Configuration->Email->Outgoing Mail Servers and check if you have one configuration line only

IBS
on 3/25/13, 8:50 AM

did that...only 1 line !!

Joshua Levy
on 3/25/13, 9:20 AM
0
Ravi
On 7/27/13, 12:34 PM

I also had the same issue with OpenERP 7.0 Scenario When the OpenERP7.0 & Mail Server is installed on the same Machine - has a challenge to configure the outgoing mail with SMTP Port 25.
While testing the SMTP Connection you get error 10061 server refused connection.
Also you cannot specify the other SMTP email server address with Port 25.

I have solved this issue by 1.Changing the Default SMTP port at the email server from 25 to 2525 and 2.In OpenERP Configuring the outgoing mails using the port 2525.

0
Joshua Levy
On 3/25/13, 4:27 AM

Hi Karim,

When I change the port from 2525 to 25 and select SSL/TLS, I get the following error:


Connection test failed!

Here is what we got instead: 10060 A connection attempt failed because the connected party did not properly respond after a period of time, or established connection failed because connected host has failed to respond

Ok


I would really appreciate some help..

Many thanks

Joshua

0

Ghanshyam Prajapati

--Ghanshyam Prajapati--
1377
| 4 4 8
Pune, India
--Ghanshyam Prajapati--
OpenERP Developer
Ghanshyam Prajapati
On 6/25/13, 3:34 AM

Try to install -

sudo apt-get install python-jinja2

if still not working then check your parameters of outgoing email server,

  • SMTP Server : smtp.gmail.com
  • SMTP Port : 587
  • Connection Security - TLS
  • Username : youremailaddresss@gmail.com
  • Password : yourpassword

If still same problem, then try as per discribe in following link to send emails.

Send eMail template through code the

Hope it work for you.

0
Amr Essam
On 6/24/13, 8:29 PM

i faced the same problem and solved it by doing the following: Changing the alias domain in General Settings to be as my domain name smtp port be 2525 connection security be (TLS/STARTTLS) finally, the priority be less than localhost or other outgoing mail

Thank you

Amr Essam

Your Answer

Please try to give a substantial answer. If you wanted to comment on the question or answer, just use the commenting tool. Please remember that you can always revise your answers - no need to answer the same question twice. Also, please don't forget to vote - it really helps to select the best questions and answers!

About This Community

This community is for professionals and enthusiasts of our products and services. Read Guidelines

Question tools

3 follower(s)

Stats

Asked: 3/24/13, 10:13 PM
Seen: 13624 times
Last updated: 3/16/15, 8:10 AM