Odoo Help


Cannot see the Stock Journal Entries of the delivered sales products

Mudi Vand
on 12/22/14, 2:21 AM 4,934 views


I have a product category 'Computers' and I configured its Account Properties and Accounting Stock Properties.

And I have selected the following configuration under Settings -> Configuration:

  • Warehouse -> Accounting -> Generate accounting entries per stock movement.
  • Purchases -> Purchase Order -> Compute product cost price based on average cost.

Then I confirm a sales order for a product under 'Computers' category, create and validate the invoice and deliver the products.

I want to see:

  • DR my Debtors account with the sales price.
  • CR my Sales Income account with the sales price.
  • DR my Cost of Sales account with the cost of goods sold.
  • CR my Inventory account with the cost of goods sold.

But I can see only the two entries related to the sales journal. What am I missing in configuring the system to pass the stock journal entries?

Thank you.

Mudi Vand
On 12/23/14, 5:33 AM


Thank you zbik for trying to help me. I tried this with the demo data as well, and it contained the 'Cost of Goods Sold' account. Therefore, I don't think it is something related with account_anglo_saxon.


Thank you too Ivan, for your answer. I knew that the stock journal is related with the delivery orders, not with the sales orders. That is why I went through the workflow upto delivery: Confirmed the Sales Order -> Validated the Invoice -> Delivered the Products. But my stock journal related accounts were not updated and I wanted to figure out what I was missing in the configuration. After seeing your answer I looked in the stock moves records too. But I couldn't see any journal records there.

Finally I found out the answer.

In the product form, I have to set the Inventory Valuation in Accounting tab as 'Real Time (Automated)'.

Then the stock journal entries are displayed in Accounting -> Journal Entries -> Journal Entries in 'Unposted' status. I can select the record and post it to the general ledger.

If I want to skip that step and post the stock journal entry directly into the general ledger, I can edit the stock journal (Accounting -> Configurations -> Journals -> Journals) and select 'Skip 'Draft' State for Manual Entries' option.

I need To Know How You solve It Bec I Have The Same Problem

on 10/21/15, 10:40 AM

Hi Yasmin, isn't my answer above clear? It is a two-step configuration. Set the Inventory Valuation as 'Real Time (Automated)' in Product form Accounting tab. Then the entries will be displayed in 'unposted' status in the stock journal; you have to post it with another button click. If you want to skip that step, modify the stock journal and select 'Skip 'Draft' State for Manual Entries' option. However, I tried this in version 7. I don't know if it is same in higher versions.

Mudi Vand
on 11/5/15, 12:31 AM


| 6 5 7
Lodz, Poland

On 12/22/14, 4:22 AM

I'm not sure what you expect, you may need install module account_anglo_saxon?

Certainly help you to read this document: https://github.com/odoo/odoo/blob/8.0/addons/account_anglo_saxon/docs/account_anglo_saxon.pdf




| 5 3 6
Jakarta, Indonesia
On 12/22/14, 5:13 AM

The stock journal is not linked to the sale order or sale journal.  It is linked to the develiry order.  From Warehouse >> Traceability >> Stock Moves menu (the menu structure may differ from yours as it depends on the modules installed), search for the stock move that has References set to the sale order's number.  Open that stock move and you can see the Journal Item table at the left bottom corner.

About This Community

This platform is for beginners and experts willing to share their Odoo knowledge. It's not a forum to discuss ideas, but a knowledge base of questions and their answers.


Odoo Training Center

Access to our E-learning platform and experience all Odoo Apps through learning videos, exercises and Quizz.

Test it now

Question tools

1 follower(s)


Asked: 12/22/14, 2:21 AM
Seen: 4934 times
Last updated: 3/16/15, 8:10 AM