Odoo Help

Welcome!

This community is for beginners and experts willing to share their Odoo knowledge. It's not a forum to discuss ideas, but a knowledge base of questions and their answers.

0

Cannot find the module 'less'

By
john sebastian salcedo henao
on 8/3/16, 6:44 PM 634 views

Hi,

Someone knows what happened with my Odoo installation ?

This is the error.

--

throw err;

^

Error: Cannot find module 'less'

at Function.Module._resolveFilename (module.js:325:15)

at Function.Module._load (module.js:276:25)

at Module.require (module.js:353:17)

at require (internal/module.js:12:17)

at Object.<anonymous> (/usr/bin/lessc:9:12)

at Module._compile (module.js:409:26)

at Object.Module._extensions..js (module.js:416:10)

at Module.load (module.js:343:32)

at Function.Module._load (module.js:300:12)

at Function.Module.runMain (module.js:441:10)

This error occured while compiling the bundle 'web.assets_common' containing:

- /web/static/src/less/mimetypes.less

- /web/static/src/less/animation.less

- /web_planner/static/src/less/web_planner_common.less

- /web_editor/static/src/less/web_editor.less

2016-08-03 22:43:30,574 2425 WARNING test openerp.addons.base.ir.ir_qweb: module.js:327

throw err;

--

I updated the node js version at for run other app that I have

Version Nodejs : v4.4.7

Which lessc:   /usr/local/bin/lessc


Thanks.




0

Hi, thanks.

I've restored one instance backup so I fixed the problem, But I need update node js to run an app that I've developed, What is the best way to update nodejs


(Sorry, my english is not good)


Hi, I've solved the problem, the problem was that my app uses Promises so the version of nodejs 0.10.25 doesn't has support, I write the app without using Promises

0
Heru Prayogo
On 8/3/16, 9:54 PM

Please try this command

sudo apt-get install node-less

0

Axel Mendoza

--Axel Mendoza--
10205
| 7 7 8
Camaguey, Cuba
--Axel Mendoza--

DevOps - Full stack - Software Architect - Developer - Technology Integrator

I could help you to develop anything and solve complex problems based on technologies, integrations and tricky stuffs mostly in Python with OpenERP/Odoo, Zato, Django and many others frameworks programming languages and technologies.

I offers consulting services to anyone with an unanswered questions or needs for customizations. Think about it, maybe it's better to have an expert to solve your issues and projects than having a full time employee trying to understand what to do an how

Reach me at aekroft@gmail.com

Axel Mendoza
On 8/3/16, 9:15 PM

Just make sure that node and lessc are correctly installed by issuing this command (examples from my laptop):

aek@aek:~$ node -v
v0.10.25

If that command doesn't work and you have nodejs installed you could fix it:

ln -s /usr/bin/nodejs /usr/bin/node


Your Answer

Please try to give a substantial answer. If you wanted to comment on the question or answer, just use the commenting tool. Please remember that you can always revise your answers - no need to answer the same question twice. Also, please don't forget to vote - it really helps to select the best questions and answers!

About This Community

This community is for professionals and enthusiasts of our products and services. Read Guidelines

Question tools

1 follower(s)

Stats

Asked: 8/3/16, 6:44 PM
Seen: 634 times
Last updated: 8/4/16, 8:23 AM