Odoo Help

Welcome!

This community is for beginners and experts willing to share their Odoo knowledge. It's not a forum to discuss ideas, but a knowledge base of questions and their answers.

1

Cannot access Openerp v7 from wlan or external internet.

By
Fred
on 3/19/13, 3:47 AM 3,383 views

I have a test version installed on a separate server and can access it just fine from my home lan over my router. when I try from a external wlan/internet it times out.

I am using a no-ip.org address. This worked fine with earlier versions.

What am I missing?

Here is the address for anyone who wants to try: afbbodenbelag.no-ip.org:8069/

Have you forwarded the port? If not it's that.

Ash Muir
on 3/19/13, 8:19 AM

It works for me here, I can access your server.

IBS
on 3/19/13, 8:51 AM

Lol, I didn't actually try. But yeah, working fine. Since it's facing the internet you should make sure your master password is not the default.

Ash Muir
on 3/19/13, 9:10 AM

Thanks guys. I think I found the culprit. It seams that noip2 was not working correctly: noip2, a second-generation Linux client for the http://no-ip.com dynamic DNS service. I'll wait for tomorrow and see if it updates correctly.

Fred
on 3/19/13, 10:26 AM

I've installed OpenErp onvirtual Ubuntu machine. I can access service from internal network on port ip-address:8069 but i can't access from outside. I've installed no-ip on ubuntu pc and forwarded port 8069 on my internet router.There is no any firewalls (all disabled). What am i missing here? Any help would be greatly appreciated!

Dragan
on 4/25/13, 5:20 PM

Dragan, as you're using a virtual machine you need to check the networking settings on whatever program you're using, there's a few ways that it can be configured and they probably won't all work. Does the virtual machine get a separate internal IP than the host machine? it'll need to for port forwarding to work properly.

Ash Muir
on 4/26/13, 8:34 AM
0
Ash Muir
On 3/19/13, 8:44 AM

I checked and the DNS is resolving fine. This is 100% some sort of firewall issue if you can access it from local network. You have to forward port 8069 to the correct computer in your router settings. If you've done that then your server is rejecting connections that don't come from local network, check your iptables (if it's a linux server).

0

Gustavo

--Gustavo--
950
| 2 1 4
Buenos Aires, Argentina
--Gustavo--

Python developer, big fan of sailing

Gustavo
On 3/19/13, 5:11 AM

can you access anyother content from outside the network? Have you tried accessing with ssh your server? Looks like a firewall issue

I don't have any other content on that server. Just OpenERP. I haven't set up any firewalls. How would I access with SSH?

Fred
on 3/19/13, 5:31 AM

Your Answer

Please try to give a substantial answer. If you wanted to comment on the question or answer, just use the commenting tool. Please remember that you can always revise your answers - no need to answer the same question twice. Also, please don't forget to vote - it really helps to select the best questions and answers!

About This Community

This community is for professionals and enthusiasts of our products and services. Read Guidelines

Question tools

0 follower(s)

Stats

Asked: 3/19/13, 3:47 AM
Seen: 3383 times
Last updated: 3/16/15, 8:10 AM