Odoo Help


This community is for beginners and experts willing to share their Odoo knowledge. It's not a forum to discuss ideas, but a knowledge base of questions and their answers.


Can't get the incoming emails into my Inbox

on 3/27/13, 5:30 PM 50,074 views


I've configured outgoing mail server and everything works fine. The problem comes with the incoming emails wich I can't read them through my inbox.

I set the incoming mail server up correctly using the same email address than my user. The system reads the incoming mails (I check my webmail and the appear as read) but it doesnt push them into the user inbox so my question is: Am i missing something? how to configurate it to receive the emails properly?

I have exactly the same problem right now ! Did you fix it ? If yes, what have you done ? Thx

erik g
on 10/23/13, 8:31 PM
@boltbike: has any of the answers actually solved your problem?
if so, please could you mark as 'answered' by clicking on the ckeck mark left of the answer (which turns from greyed out to green when you do that)
on 3/19/15, 9:07 PM

Fabrice Henrion (fhe)

--Fabrice Henrion (fhe)--
| 7 7 8
San Francisco, United States
--Fabrice Henrion (fhe)--

Director Odoo USA

Fabrice Henrion (fhe)
On 3/28/13, 5:59 AM

I think you are missing the point of the user inbox (in the "Messaging" tab of OpenERP). The goal is not to reflect your regular email inbox by fetching all the emails you receive in it. The goal of the Inbox in Messaging tab is to centralize all the OpenERP notifications that you could receive in the context of OpenERP (typically for the documents you "follow").

On the other hand, you can set up in your user preferences (top right corner) that you want a copy of these notifications in your regular email for your convenience. To allow this, you need to make sure that you have an outgoing email server properly set up.

As you can see, using the Inbox of the Messaging tab doesn't require an incoming email server.

Juan Formoso
On 5/11/15, 5:09 AM

I did the next steps and they worked perfectly on my computer... however, I don't know why but it's not working on the computer I need to implement this. May be it's going to work for you too.

1. Configuration > Configuration > General Settings, section domain alias, turn it to yours (example: if your address is myaddress@gmail.com, set this to gmail.com).

2. Configuration > Users > Users, select one user (the admin, for example) and go to their Preferences tab. Set their messaging alias to your account alias (example: if your address is myaddress@gnail.com, set this to myaddress).

Note: in this step, if you save and your address turns to myaddress2, it will be because you declared first the incoming mail server and Odoo created an alias for it. You have to delete that alias from Configuration > Email > Aliases. After removing that row, you will be able to save the user with that alias and Odoo won't turn it to myaddress2.

3. Create your incoming mail server. Configuration > Technical > Incoming Mail Servers, create a new one. (Let's put an example with IMAP: set the name: whichever you want, server type: IMAP server, server name: imap@gmail.com -if your address is a google one-, port: 993, SSL/TLS: True, user: myaddress@gmail.com, password: pwd_of_your_account). Click on Test & confirm and it will be configured.

4. Now go to Configuration > Automation > Scheduled Actions, and edit the Fetchmail service row. Set the attributes Interval Number to 1 and Interval Unit to Minutes, to check if there are incoming mails each minute (this way you will see if it works faster).

It worked for me, but now, I can't understand why ithe same steps are't working on other computer... If anyone could give me a hint, it would be very appreciated.

awesome, worked for me. I had not done step 2.... and had to redo step 3 again afterwards. Doing this wrong at first caused some hanging mailloop today with some gigs of weird traffic between odoo and our mailserver.

Peter Niederlag
on 12/10/15, 3:46 PM
On 3/28/13, 6:19 AM

You can check that emails are being picked up (which they must be if they are being marked as read) by going into Settings->Technical->E-mail->Messages. This allows you to view all messages (note that this will be a combination of mail.messages generated from incoming emails and other messages generated by openERP). Note that to do this you will need technical features enabled (https://accounts.openerp.com/forum/Help-1/question/7650/).

Messages can be sent to your user inbox by using email aliases for your users. By default a users alias will be his login (https://accounts.openerp.com/forum/Help-1/question/3069/).

Carl Lalonde
On 10/1/14, 8:10 AM


I need my incomming e-mail in the openerp 8 "inbox" for all user like a typical mailbox for a lot of reasons. I can see that a i need to use alias but i don't fully understand, is someone can help me to disociate some possibility founded after a google research.

If i can to what i wanna do with the alias fonction, why some forum talk about the "add record" and "server action" from the incomming server option. Also is every user will be able to view email of each other? cause this will be bad :/

Maybe you need to know that my mail account is on my hosted domain, and my OperERP is on my private server, my domain just point to my private server.


Thanks a lot!


This space is for answers. If you have a new question (although related) you should ask a new question.

Pau Ubach
on 10/14/14, 11:57 PM
On 6/21/14, 3:13 AM

I have a mail account in google gmail. I want to receive and send reply mail through with in openerp system. How to configure this.. As like mail client....Kindly help me.. Thanks in advance

This space is for answers. If you have a new question (although related) you should ask a new question.

Pau Ubach
on 10/14/14, 11:57 PM
Landis Arnold
On 3/19/15, 6:40 PM

I just spent a few hours on this.  First no mail was flowing, thought now it seems like things are working (hopefully it will not be too difficult for the customers outside).

Process was:

  • setup Catchall Domain  (erp.mydomain.com)

  • setup 1 account on domain erp@erp.mydomain.com

  • setup incoming and out going servers in Settings / General

  • changed the value in Settings/Technical/Paramaters/System Parameters  for mail.catchall.alias to erp  (from catchall)

 This means that the "reply to" address becomes the Odoo Server  and looks ok too.  (erp@erp.mydomain.com)

I find that testing mails generated from ERP and replied to (for instance as a lead) the mail is routing, and I am actually getting the email on the outside to my Inbox, and my "testing other" lead-inbox.

I would imagine there are actions that can break this but so far it looks quite promising for keeping ERP activities within erp.  I am not clear on the changes from 7 to 8, but I did notice the "email alias" for a USER is quite separated from the Partner Email which the USER is associated with.  I expect there is considerable confusion about this but for myself, this has seemed to help.

I did test removing mail.catchall.alias as recommended elsewhere here but I found the SYSTEM then was losing messages  (not verified as yet).  There is a lag in all this.  Maybe 5 minutes for messages to get routed through the system and back out.

Finally, I do recomend fully testing this before going live.  It seems super powerful but conceptually quite dangerous.  Folks really do not like new email addresses showing up.  Not sure that I do either.

My answer for now  (first look)

(Follow UP)

On a different Database I found that user aliases were not enabled until I renamed my email domain alias to something other than the server's domain itself.  Doing so activated the ability to assign email-alias@domain to each user.  Likely was waiting for some entry into the field.  This is important to do even if the MX record for the Odoo Domain is the same Email domain you will be using as you will not get effective use of your users email possiblities with odoo.

This is a complicated overall subject that is not well documented.  Amazing things in the system but somewhat complicated to follow.  Changes between OpenERP 7 and Odoo 8 complicate it as much of the Web References are towards v 7 implementation.

Your Answer

Please try to give a substantial answer. If you wanted to comment on the question or answer, just use the commenting tool. Please remember that you can always revise your answers - no need to answer the same question twice. Also, please don't forget to vote - it really helps to select the best questions and answers!

About This Community

This community is for professionals and enthusiasts of our products and services. Read Guidelines

Question tools

32 follower(s)


Asked: 3/27/13, 5:30 PM
Seen: 50074 times
Last updated: 10/21/16, 11:41 PM