Help

4

Can't get FTP to work on OpenERP7? Any help?

Avatar
eric machine

Hi everyone,

I can't seem to get FTP to work here.

ftp: // 192.168.1.100:8021 / mycompany (ignore spaces, as I can't publish link)

My openerp-server.conf as follows

ftp_server_host = 192.168.1.100

ftp_server_port = 8021

ftp_server_passive_ports = 80210:80310

Installed the document, document_ftp and document_webdav modules.

I can access openerp website, but I just can't get my FTP to work on firefox/chrome/safari and cyberduck too.

I tried to install vsftpd, but i couldn't figure out how to change the listen_port = 8021 instead of 21.

Tested on Ubuntu 12.04 server.

Do I need to install anything extra to make FTP to work?

4 Comments
Avatar
Discard
Avatar
Tomás Pascual
-

1.- You must create system parameter ir_attachment.location with value file:///filestore

2.- You must create in server and under openerp the folder "filestore/dbname"

3.- You must give chown (dbuser) to all openerp files and folders

4.- I have not this line in my config file ftp_server_passive_ports = 80210:80310

Avatar
Tomás Pascual
-

5.- You must be first connected to openerp:8069 and then the FTP conection will run

Avatar
Richelle Laurent
-

Hello Tomas, not sure to understand what you mean about (dbuser) ! Could you be more explicit? Do you mean apache or openerp linux system account?

Avatar
Tomás Pascual
-

Sorry, posgresql user that is configured in openerp-server.conf In my case, openerp