Odoo Help

Welcome!

This community is for beginners and experts willing to share their Odoo knowledge. It's not a forum to discuss ideas, but a knowledge base of questions and their answers.

1

Can't create nonconformities?

By
Simon Buckmaster
on 4/9/13, 11:46 AM 1,135 views

Hi,

I have installed OpenERP 7 on a dedicated LAPP server (12.04 LTS), set up a database, company users etc. I appear to have a functioning install.

I have installed the openerp_mgmtsystem module in order to create/manage nonconformities, but I am having some trouble with permissions (I think?)…

Basically, when logged in as admin everything works as expected. However, when logged in as another user I cannot create nonconformities - the button to create them is missing.

Can anyone with any experience with this module point me in the right direction? I believe I have tried any/all combinations of group permissions which have an effect in so far as they enable or disable sections of the Management System (openerp_mgmtsystem) module, yet the elusive button for creating nonconformities remains missing for all users except for admin.

Thanks in advance!

Simon

0
Simon Buckmaster
On 4/10/13, 5:40 AM

This was indeed a bug, fix has already been released.

0
Simon Buckmaster
On 4/9/13, 12:40 PM

Is there somewhere other than the user settings page where I need to be setting groups?

I have tried all combinations of groups (viewer/user/approving user/auditor/manager) in the Management System user settings…

Thanks for your help…

0

Daniel Reis

--Daniel Reis--
3436
| 6 7 9
Lisbon, Portugal
--Daniel Reis--

Author of the "Odoo Development Essentials" book.

Applications Manager at Securitas Portugal

Github: https://github.com/dreispt

Twitter; @reis_pt


Daniel Reis
On 4/9/13, 12:33 PM

Make sure you add your users to the "Management System User" group.

Is there somewhere other than the user settings page where I need to be setting groups?

I have tried all combinations of groups (viewer/user/approving user/auditor/manager) in the Management System user settings…

Thanks for your help…

Simon Buckmaster
on 4/9/13, 12:40 PM

Looks like you found a bug.

Daniel Reis
on 4/9/13, 7:16 PM

Your Answer

Please try to give a substantial answer. If you wanted to comment on the question or answer, just use the commenting tool. Please remember that you can always revise your answers - no need to answer the same question twice. Also, please don't forget to vote - it really helps to select the best questions and answers!

About This Community

This community is for professionals and enthusiasts of our products and services. Read Guidelines

Question tools

1 follower(s)

Stats

Asked: 4/9/13, 11:46 AM
Seen: 1135 times
Last updated: 3/16/15, 8:10 AM