Odoo Help

Welcome!

This community is for beginners and experts willing to share their Odoo knowledge. It's not a forum to discuss ideas, but a knowledge base of questions and their answers.

1

Can openERP 6.1 be accessed by (http://erp.mydomain.com) instead of (https) ?

By
Arsi
on 8/28/13, 6:22 AM 2,337 views

Hi,

I had made a server of openerp. From browser it was accessable by http ://ip:8069 I wanted to rip the 8069 port... I searched and installed the Nginx after that I was able to access by HTTPS ://ip also. And if i put http ://ip , it redirects me to HTTPS. HTTPS requires SSL certificate else it gives the security check everytime the browser is opened.

Is there a possibility to access the server by http :// ip ??

1

Brett Lehrer

--Brett Lehrer--
1252
| 5 4 8
Milwaukee, United States
--Brett Lehrer--
Director of IT and open source enthusiast.
Brett Lehrer
On 8/28/13, 3:52 PM

Sure, you could configure it that way, but I'd recommend against it if it's a public-facing server. You shouldn't be sending your login credentials over an unencrypted connection. RapidSSL sells certificates for $49/year IIRC, worth it to get around the browser hassle, and much better than having no encryption.

You could also be deploying your self-signed certificate internally, but that's not really an OpenERP subject.

Or get a free certificate from StartSSL => http://www.startssl.com

George Appiah
on 8/31/13, 12:20 PM

Very interesting. Curious to see how a class 1 certificate would work in an application like that.

Brett Lehrer
on 8/31/13, 6:51 PM

I made it work with HTTPS ://mydomain.com

Arsi
on 9/29/13, 7:30 AM
0
Mustafa Rawi
On 9/29/13, 3:12 PM

Open your site configuration file in sites-enabled and replace its contents with: (Don't forget it back it up)

server {
  listen 80;
  send_timeout 600;
  client_max_body_size 256M;
  server_name example . com example . org;
  location / {
    proxy_pass h t t p: // localhost:8069;
  }
}

Restart Nginx and test. The lines:

  send_timeout 600;
  client_max_body_size 256M;

are for my use case. You are free to adjust or remove them. Sorry, I can't post links, so remove extra spaces.

0
Arsi
On 9/29/13, 7:31 AM

I made it work with HTTP ://mydomain.com through the router configuration

Inyway to get a bit more info on how you did it?

dfor mer
on 9/29/13, 10:45 AM

I just bind the ipaddress:8069 to the HTTP://domainname from the network settings :)

Arsi
on 9/30/13, 5:25 AM

Your Answer

Please try to give a substantial answer. If you wanted to comment on the question or answer, just use the commenting tool. Please remember that you can always revise your answers - no need to answer the same question twice. Also, please don't forget to vote - it really helps to select the best questions and answers!

About This Community

This community is for professionals and enthusiasts of our products and services. Read Guidelines

Question tools

0 follower(s)

Stats

Asked: 8/28/13, 6:22 AM
Seen: 2337 times
Last updated: 3/16/15, 8:10 AM