Odoo Help


This community is for beginners and experts willing to share their Odoo knowledge. It's not a forum to discuss ideas, but a knowledge base of questions and their answers.


Can not install Accounting Module

on 5/28/13, 5:34 AM 1,457 views

I have problem when install Accounting Module the error bellow I remove openERP and re install it

and also remove PostgreSQL but the problem is the same why?

the error is

OpenERP Server Error
Client Traceback (most recent call last):
    File "C:\Program Files (x86)\OpenERP 7.0-20130407-232401\Server\server\openerp\addons\web\http.py", line 203, in dispatch
    File "C:\Program Files (x86)\OpenERP 7.0-20130407-232401\Server\server\openerp\addons\web\controllers\main.py", line 1133, in call_button
    File "C:\Program Files (x86)\OpenERP 7.0-20130407-232401\Server\server\openerp\addons\web\controllers\main.py", line 1121, in _call_kw
    File "C:\Program Files (x86)\OpenERP 7.0-20130407-232401\Server\server\openerp\addons\web\session.py", line 43, in proxy
    File "C:\Program Files (x86)\OpenERP 7.0-20130407-232401\Server\server\openerp\addons\web\session.py", line 31, in proxy_method
    File "C:\Program Files (x86)\OpenERP 7.0-20130407-232401\Server\server\openerp\addons\web\session.py", line 104, in send

Server Traceback (most recent call last):
    File "C:\Program Files (x86)\OpenERP 7.0-20130407-232401\Server\server\openerp\addons\web\session.py", line 90, in send
    File "C:\Program Files (x86)\OpenERP 7.0-20130407-232401\Server\server\.\openerp\netsvc.py", line 293, in dispatch_rpc
    File "C:\Program Files (x86)\OpenERP 7.0-20130407-232401\Server\server\.\openerp\service\web_services.py", line 626, in dispatch
    File "C:\Program Files (x86)\OpenERP 7.0-20130407-232401\Server\server\.\openerp\osv\osv.py", line 188, in execute_kw
    File "C:\Program Files (x86)\OpenERP 7.0-20130407-232401\Server\server\.\openerp\osv\osv.py", line 131, in wrapper
    File "C:\Program Files (x86)\OpenERP 7.0-20130407-232401\Server\server\.\openerp\osv\osv.py", line 197, in execute
    File "C:\Program Files (x86)\OpenERP 7.0-20130407-232401\Server\server\.\openerp\osv\osv.py", line 185, in execute_cr
    File "C:\Program Files (x86)\OpenERP 7.0-20130407-232401\Server\server\openerp\addons\base\module\module.py", line 713, in install_from_urls
    File "C:\Program Files (x86)\OpenERP 7.0-20130407-232401\Server\server\openerp\addons\base\module\module.py", line 424, in button_immediate_install
    File "C:\Program Files (x86)\OpenERP 7.0-20130407-232401\Server\server\openerp\addons\base\module\module.py", line 475, in _button_immediate_function
    File "C:\Program Files (x86)\OpenERP 7.0-20130407-232401\Server\server\.\openerp\pooler.py", line 39, in restart_pool
    File "C:\Program Files (x86)\OpenERP 7.0-20130407-232401\Server\server\.\openerp\modules\registry.py", line 218, in new
    File "C:\Program Files (x86)\OpenERP 7.0-20130407-232401\Server\server\.\openerp\modules\loading.py", line 348, in load_modules
    File "C:\Program Files (x86)\OpenERP 7.0-20130407-232401\Server\server\.\openerp\modules\loading.py", line 259, in load_marked_modules
    File "C:\Program Files (x86)\OpenERP 7.0-20130407-232401\Server\server\.\openerp\modules\loading.py", line 168, in load_module_graph
    File "C:\Program Files (x86)\OpenERP 7.0-20130407-232401\Server\server\.\openerp\modules\module.py", line 385, in init_module_models
    File "C:\Program Files (x86)\OpenERP 7.0-20130407-232401\Server\server\.\openerp\osv\orm.py", line 2787, in _update_store
    File "C:\Program Files (x86)\OpenERP 7.0-20130407-232401\Server\server\.\openerp\osv\fields.py", line 1131, in get
    File "C:\Program Files (x86)\OpenERP 7.0-20130407-232401\Server\server\.\openerp\osv\fields.py", line 1197, in _fnct_read
    File "C:\Program Files (x86)\OpenERP 7.0-20130407-232401\Server\server\.\openerp\osv\orm.py", line 383, in __getitem__
    KeyError: "Field 'commercial_partner_id' does not exist in object 'browse_record(res.partner, 21)'"


| 5 4 7
Baarn, Netherlands
On 5/28/13, 5:37 PM

According to this question and the answer given, there is a bug with a specific module. If I remember correctly (no install op OE7 with me at the moment), there is a tick you have to place at the settings within OE7 to enable this module.

Your Answer

Please try to give a substantial answer. If you wanted to comment on the question or answer, just use the commenting tool. Please remember that you can always revise your answers - no need to answer the same question twice. Also, please don't forget to vote - it really helps to select the best questions and answers!

About This Community

This community is for professionals and enthusiasts of our products and services. Read Guidelines

Question tools

0 follower(s)


Asked: 5/28/13, 5:34 AM
Seen: 1457 times
Last updated: 3/16/15, 8:10 AM