Odoo Help


This community is for beginners and experts willing to share their Odoo knowledge. It's not a forum to discuss ideas, but a knowledge base of questions and their answers.


Can no longer Browse to Odoo server, just spins on an on

on 2/6/16, 8:13 AM 464 views

I have a brand new Odoo 9 server running on Ubuntu. Install went well everything seemed to be working fine, was able to browse, configured database, all good.

Installed a few modules all good. Not sure which module I tried to install, (I think it was Mailing Campaigns) and it seems to have just hung...since then I have not been able to render any browser pages. I have restarted the services, rebooted the server to no avail.

I have verified log files and odoo server seems to start fine. When I browse there, it does not error out, it just spins endlessly, as if it is trying to render but can't. I have tried everything I know. I am fairly new to Odoo.  Also Telnet to the 8069 port seems ok. Below are the last few lines of my log file.

2016-02-06 12:48:31,692 14326 INFO ? openerp.service.server: Initiating shutdown

2016-02-06 12:48:31,692 14326 INFO ? openerp.service.server: Hit CTRL-C again or send a second signal to force the shutdown.

2016-02-06 12:49:09,582 14946 INFO ? openerp: OpenERP version 9.0c

2016-02-06 12:49:09,582 14946 INFO ? openerp: addons paths: ['/opt/odoo/.local/share/Odoo/addons/9.0', u'/opt/odoo/addons', '/opt/odoo/openerp/addons']

2016-02-06 12:49:09,582 14946 INFO ? openerp: database: odoo@default:default

2016-02-06 12:49:09,738 14946 INFO ? openerp.service.server: HTTP service (werkzeug) running on

S. Edelman
On 9/13/16, 9:50 AM

This same issue happened to me too now.

I can't recall making anything special to cause it. The system has been running since July, and we have used web module, inventory, added products, tested sales quotations etc. We had also built already a website there, all running smoothly. Now I haven't looked for 3 days and during that something has happened, and my web browser is just saying that the "server is not responding". If I try to view via mobile phone browser, it says "Internal Server Error".

In the server logs there is nothing special but it gives quite exactly the same log than here is described as well in this thread. I can't find anything that would be wrong in order to start fixing it. It also has to be something that have gone bad by itself since all the settings have been running few months without problems.

Did you find anything to solve this in your case?

Checked once more the config (/etc/odoo-server.conf), and it had a line like this:
db_host = localhost

I changed it to:
db_host = False

After that I restarted the server (sudo /etc/init.d/odoo-server restart). Refreshing the website and it came back after almost a month trying to find a solution! In the end I changed only ONE word in this config. I hope this helps somebody else since it was not easy to find out tips for this issue.

(In my opinion I had done this same config edit earlier though but not sure, at least now this worked!)

Still having the same issue. I'm unable to find anything wrong with the server configs, nothing had been changed this in order to cause the disappearance of the Odoo.

S. Edelman
on 9/29/16, 10:23 AM
Shyam Kishore
On 9/13/16, 11:42 AM

It could be a JS conflict. The new module you installed might have some issue in JS. I had faced this issue when I was trying to install an Odoo 8 app into Odoo 9.

To get the exact issue, click the "F12" button in chrome browser when the page starts loading. You will get the issue in console.

Hope this helps!

I have not installed any new module. I also have done that earlier with ANOTHER Odoo install that the custom module affected like this but in this case there is only standard modules.

Debugging with Chrome doesn't help because it goes straight to a page "This site can’t be reached", so no point to debug that one. I did try though that too.

This is a disaster since the site has lot of info already and it should be under content development. Where to continue debugging?

I noticed that the odoo log stops when getting odoo-server running after it has shutdown. Then there are lines:

File "/usr/lib/python2.7/dist-packages/psycopg2/__init__.py", line 164, in connect

conn = _connect(dsn, connection_factory=connection_factory, async=async)

OperationalError: fe_sendauth: no password supplied

2016-09-13 19:06:37,351 7409 INFO ? openerp.addons.bus.models.bus: Bus.loop listen imbus on db postgres

Could there be some change in python language? Update that has caused the password authentication not work like before?

S. Edelman
on 9/14/16, 2:35 AM
Aziz Yemloul
On 2/14/16, 6:57 PM

2016-02-06 12:49:09,582 14946 INFO ? openerp: database: odoo@default:default

It looks to me like the values of default:default after the @ are not correctly replaced.

It should be something like :

database hostname: localhost

database port: 5432

database user: odoo

I'am trying to figure out how to solve this too.

Your Answer

Please try to give a substantial answer. If you wanted to comment on the question or answer, just use the commenting tool. Please remember that you can always revise your answers - no need to answer the same question twice. Also, please don't forget to vote - it really helps to select the best questions and answers!

About This Community

This community is for professionals and enthusiasts of our products and services. Read Guidelines

Question tools

2 follower(s)


Asked: 2/6/16, 8:13 AM
Seen: 464 times
Last updated: 9/14/16, 2:36 AM