Odoo Help


This community is for beginners and experts willing to share their Odoo knowledge. It's not a forum to discuss ideas, but a knowledge base of questions and their answers.


can i run my server on localhost instead of localhost:8069?

on 2/13/15, 2:20 PM 1,919 views

My client buy a domain name service with vps. I ahve installed odoo=8 on that vps and asked him to type like http://domain name:8069. My client don't want to type that :8069 after domain name. How can i configure odoo ? when i run server like

./odoo.py --addons ./addons,../custom/addons --xmlrpc-port=80. It is showing error permission denied.


Martin Temmink
On 2/13/15, 7:08 PM

Yes, that's possible, you can set the port like you mentioned.

But beware! port 80 is often used by apache, ngix or internet server softtware on your server. And if thats the case, you cannot run a second piece of software on the same port.

Also your current user is maybe not allowed to use port below 1023.



Med Said BARA

--Med Said BARA--
| 5 5 7
--Med Said BARA--
Med Said BARA
On 2/14/15, 10:41 AM

Try to use Nginx

Just follow the steps described in the section Install and Configure Nginx (only this section)( https://www.rosehosting.com/blog/install-odoo-formerly-openerp-with-nginx-on-an-ubuntu-vps/ )


Thank you BARA, Can you give me some more information regarding this. When look into youtube videos, they are mentioning only installation and configuration of php. How can i configure odoo with nginx?

on 2/17/15, 4:04 AM
On 2/14/15, 3:31 AM

yes it is posible

Dominique Chabord
On 2/14/15, 8:29 AM

https secure protocol is a minimal requirement for any erp exposed to internet. You need a proxy to redirect 80 to 443, exchange the certificate and then proxy 443 to 8069. Nating port 80 to 8069 provides no protection at all.

On 2/14/15, 4:02 AM

Just use iptables in terminal

iptables -t nat -A PREROUTING -i eth0 -p tcp --dport 80 -j REDIRECT --to-port 8069

The above rule will redirect your 80 port to 8069

Thank you Jothimani. I did but not working.

on 2/14/15, 7:35 AM

i'm running by the same, anyway i give another one. Install nginx in your VPS. upstream openerp_servers{ server localhost:8069 max_fails=3 fail_timeout=30s; } server { listen 80; server_name example.com; } location /{ proxy_pass http://openerp_servers; proxy_next_upstream error timeout invalid_header http_500 http_502 http_503 http_504; proxy_redirect off; proxy_set_header Host $http_host; proxy_set_header X-Real-IP $remote_addr; proxy_set_header X-Forwarded-For $proxy_add_x_forwarded_for; proxy_set_header X-Forwarded-Proto https; } } location ~* /web/static/ { proxy_cache_valid 200 60m; proxy_buffering on; expires 864000; proxy_pass http://openerp_servers; } save this configuration in your nginx config file as /etc/nginx/sites-enabled/server.com

on 2/14/15, 7:43 AM

Apache running on port 80

on 2/17/15, 4:01 AM

Your Answer

Please try to give a substantial answer. If you wanted to comment on the question or answer, just use the commenting tool. Please remember that you can always revise your answers - no need to answer the same question twice. Also, please don't forget to vote - it really helps to select the best questions and answers!

About This Community

This community is for professionals and enthusiasts of our products and services. Read Guidelines

Question tools

3 follower(s)


Asked: 2/13/15, 2:20 PM
Seen: 1919 times
Last updated: 3/16/15, 8:10 AM