Odoo Help


button 'receive invoice' doesn't appear. can anyone help me?

giovanni crisona
on 2/9/15, 8:17 AM 703 views

hello experts, I have a problem:  after having confirmed the order, the button 'receive invoice' doesn't appear, I noted that in the db the field invoiced in the purchase_order_line is alwais 0 in all the records. I checked the permissions in groups and i didn't note any difference form another installation where the button, after order confirmation, appears. Some one could help me where to point the attention??

Thank you in advance



| 6 5 7
Lodz, Poland

On 2/9/15, 9:15 AM

You go to Settings/Purchases and find how you set option Invoicing Settings: Default invoicing control method.

Invoicing Method:

  • Based on Purchase Order lines: place individual lines in Invoice Control / On Purchase Order lines from where you can selectively create an invoice.
  • Based on generated invoice: create a draft invoice you can validate later.
  • Based on incoming shipments: let you create an invoice when receipts are validated.

This link may help: Openrp Book


giovanni crisona
On 2/9/15, 12:54 PM

thank you very much zbik! I set the purchase option on 'Based on generated draft invoice' and the button appears. I have found that the same can be set even in each invoice, but I didn't understand the difference.


Anyone know a link to documentation where this could be explained? 

answer updated

on 2/9/15, 1:19 PM

thank you zbik, your suggestions are very useful. I have clearly understood now and the link is also useful. best regards

giovanni crisona
on 2/9/15, 2:13 PM

About This Community

This platform is for beginners and experts willing to share their Odoo knowledge. It's not a forum to discuss ideas, but a knowledge base of questions and their answers.


Odoo Training Center

Access to our E-learning platform and experience all Odoo Apps through learning videos, exercises and Quizz.

Test it now

Question tools

1 follower(s)


Asked: 2/9/15, 8:17 AM
Seen: 703 times
Last updated: 3/16/15, 8:10 AM