Odoo Help

Welcome!

This community is for beginners and experts willing to share their Odoo knowledge. It's not a forum to discuss ideas, but a knowledge base of questions and their answers.

0

Blank white page after login.

By
Constantine
on 3/10/16, 8:31 AM 1,036 views

I have edited qweb report templates , after saving, i refreshed page and got 404 error in popup window. I had this error earlier, and solve it with logout / login. I logged out, and after log in, it shows only favicon of our company , and nothing more.
I tried different browsers (google chrome, opera, internet explorer), clear history (cache and etc.), have tried to login with all available users for login,also i deleted sessions files on odoo server (in debian it was in /var/lib/odoo/.local/share/Odoo/sessions ), 
restarted postgresql and odoo several times, log in from 4 different machines -  nothing helps.
Most strange thing, that i can login in different database, or create new database, and don't have any problem at all. But when i copy my database in database manager, and login in copy, i have same problem - blank page.
There was session on other host while i'm working, and it seems , now only from these computer we can login in that database with no issues.
Also , i have those error in browser console:

web:15 Uncaught ReferenceError: odoo is not defined  
web.assets_backend.js:3 Uncaught ReferenceError: jQuery is not defined

web:28 Uncaught ReferenceError: $ is not defined
When i login, i got this output in log file:

2016-03-10 13:18:15,405 5878 INFO lsv_by werkzeug: 172.16.0.16 - - [10/Mar/2016 13:18:15] "POST /longpolling/poll HTTP/1.1" 200 -

2016-03-10 13:18:16,183 5878 INFO lsv_by werkzeug: 172.16.0.16 - - [10/Mar/2016 13:18:16] "POST /calendar/notify HTTP/1.1" 200 -

2016-03-10 13:19:05,456 5878 INFO lsv_by werkzeug: 172.16.0.16 - - [10/Mar/2016 13:19:05] "POST /longpolling/poll HTTP/1.1" 200 -

2016-03-10 13:19:28,997 5878 INFO lsv_by werkzeug: 172.16.0.15 - - [10/Mar/2016 13:19:28] "GET /web/login HTTP/1.1" 200 -

2016-03-10 13:19:31,443 5878 INFO lsv_by werkzeug: 172.16.0.15 - - [10/Mar/2016 13:19:31] "POST /web/login HTTP/1.1" 200 -

2016-03-10 13:19:33,813 5878 INFO lsv_by werkzeug: 172.16.0.15 - - [10/Mar/2016 13:19:33] "GET /web HTTP/1.1" 200 -

Is there any table in database, that writes session history, or something simillar, that ruins login process?

After login, i had redirected to this page: http://my.host:8069/web Normally , after this, it redirect to page like this http://my.host:8069/web#menu_id=96&action=92&active_id=channel_inbox But this not happens. I tried to paste it manually, but this doesn't help.

Constantine
on 3/10/16, 8:45 AM

Your Answer

Please try to give a substantial answer. If you wanted to comment on the question or answer, just use the commenting tool. Please remember that you can always revise your answers - no need to answer the same question twice. Also, please don't forget to vote - it really helps to select the best questions and answers!

About This Community

This community is for professionals and enthusiasts of our products and services. Read Guidelines

Question tools

2 follower(s)

Stats

Asked: 3/10/16, 8:31 AM
Seen: 1036 times
Last updated: 6/20/16, 4:40 AM