Odoo Help

Welcome!

This community is for beginners and experts willing to share their Odoo knowledge. It's not a forum to discuss ideas, but a knowledge base of questions and their answers.

0

Blank login page after restart of server

v7
By
Ankur Shah
on 3/25/13, 7:27 AM 1,602 views

After the initial setup, the login page came up fine and I was able to login, create users, do a few things. But after the restart of the server, the login page doesn't seem to come up at all. The page loads up without any errors. I see the access logs showing the GETs and POSTs successfully, but the login page doesn't seem to come up.

I'm guessing it's probably related to the password in postgres. How do I troubleshoot that?

Any pointers are greatly appreciated

Please go to your OpenERP server, press CTRL+U in your browser, paste the content of the page that pops up here: http://pastebin.com/ and give us the link

IBS
on 3/25/13, 8:52 AM

Thanks for the comment. Here it is http://pastebin.com/7DHAJuPL

Ankur Shah
on 3/25/13, 8:56 AM

Thank you, have you tried resetting your browser's cache+cookies?

IBS
on 3/25/13, 8:59 AM

Yes. Did force reload and even tried restarting the browser to trying different browsers. Same result.

Ankur Shah
on 3/25/13, 9:07 AM

If you are using windows, open your task manager, go to services and restart the PostgreSQL service.

IBS
on 3/25/13, 9:16 AM

Restarted postgres on my linux server. Still no luck.

Ankur Shah
on 3/25/13, 9:54 AM

Are you running a local server? or an online one, if it's online, could you share with us the link and you can edit it out later.

IBS
on 3/25/13, 10:13 AM

It seems like I'm running into an error that I see thrown in my JavaScript console "Uncaught Error: QWeb2: Template 'WebClient' not found".

Would you know how to fix that?

Ankur Shah
on 3/29/13, 11:21 AM

Can you paste the content of this file: addons/web/static/src/xml/base.xml in http://pastebin.com/ and provide the link here.

IBS
on 3/29/13, 12:23 PM

Thanks for the reply Karim! I've got two base.xml files. Which one would you like to see (or both)?

./usr/lib/pymodules/python2.7/openerp/addons/web/static/src/xml/base.xml ./usr/share/pyshared/openerp/addons/web/static/src/xml/base.xml

Ankur Shah
on 3/29/13, 12:32 PM

No problem, send them both.

IBS
on 3/29/13, 1:07 PM

I'm not in front of the computer, but what's interesting is that I can get to the page from everywhere other than my Macbook. Can you think of why it's specific to me? I've tried all browsers - Chrome, Safari and Firefox and getting the same error!

Ankur Shah
on 3/29/13, 1:24 PM

I'm finally able to semi-resolve the problem! There were two problems. The bigger was one was a faulty ethernet cable due to which packets were dropped over the network. After I fixed that, secondly, and more strangely, when I access openERP over one of my Wi-Fi connections I get that error. But if I access it over any other network, the page comes up fine.

Not caring about the wifi-related issue, I'm closing this as "Resolved". Thanks for the replies Karim!

Ankur Shah
on 3/31/13, 4:38 AM
1
Ankur Shah
On 3/31/13, 4:38 AM

I'm finally able to semi-resolve the problem! There were two problems. The bigger was one was a faulty ethernet cable due to which packets were dropped over the network. After I fixed that, secondly, and more strangely, when I access openERP over one of my Wi-Fi connections I get that error. But if I access it over any other network, the page comes up fine.

Not caring about the wifi-related issue, I'm closing this as "Resolved". Thanks for the replies Karim!

No problem.

IBS
on 3/31/13, 11:41 AM

Your Answer

Please try to give a substantial answer. If you wanted to comment on the question or answer, just use the commenting tool. Please remember that you can always revise your answers - no need to answer the same question twice. Also, please don't forget to vote - it really helps to select the best questions and answers!

About This Community

This community is for professionals and enthusiasts of our products and services. Read Guidelines

Question tools

1 follower(s)

Stats

Asked: 3/25/13, 7:27 AM
Seen: 1602 times
Last updated: 3/16/15, 8:10 AM