Odoo Help


This community is for beginners and experts willing to share their Odoo knowledge. It's not a forum to discuss ideas, but a knowledge base of questions and their answers.


Base Report Designer and Invoice File not working

Damian Phang
on 2/11/14, 8:32 AM 1,009 views

Open Office can download and open the file. The file could be edited and uploaded but changes do not stick. This only happens to the existing report invoice/invoice. How do I edit the file?

On 2/12/14, 3:13 AM

You have to make know the system that there is a modified template and that it should use this one instead of the old one. Go to Settings --> Configuration --> Actions --> Reports (or similar) and search for account.invoice. Open this report action template and modify it by removing the flag for 'reload from attachment' and store template. Now, your modified report layout should be used.

Damian Phang
On 2/13/14, 3:49 PM

Yup I figured that out after messing around with it. Both answers are correct, so I picked the earlier one. Thanks a bunch!


Parth Gajjar

--Parth Gajjar--
| 3 3 5
Ahmadabad, India
--Parth Gajjar--
Parth Gajjar
On 2/13/14, 6:48 AM


If you print any report and then openerp make an entry of that report in ir.attechment and if you print that report again then it will return same report.

So just go in Setting > Technical > Low Level Object > Attachments and delete entries related to your reports. And then print reports.


you can print that report from any newly created record


Your Answer

Please try to give a substantial answer. If you wanted to comment on the question or answer, just use the commenting tool. Please remember that you can always revise your answers - no need to answer the same question twice. Also, please don't forget to vote - it really helps to select the best questions and answers!

About This Community

This community is for professionals and enthusiasts of our products and services. Read Guidelines

Question tools

1 follower(s)


Asked: 2/11/14, 8:32 AM
Seen: 1009 times
Last updated: 3/16/15, 8:10 AM