Odoo Help

1
23 Answers
0
Odoo It now
2/17/19, 12:50 PM

Hello,

Type following command in terminal:

sudo nautilus

The system will open a file directory with full access and then you can Backup/Restore a filestore.

Restart the server and you will get back all the files in the database.
 
I hope it will help you.

Thank you.

0
Gagea Alexandru
3/16/18, 5:41 AM

Hello, did you manage to find a solution for your problem ?

15 Comments
inian
3/16/18, 5:47 AM

No, I could backup/restore completely with file store, only with User interface.

Gagea Alexandru
3/16/18, 5:50 AM

All of a suddent i can't backup an odoo database.. with no reason and no relevant error, and if i perform backup and restore from pgadmin i dont get the filestore, can't event find the location of the filestore..

inian
3/16/18, 5:54 AM

can you still connect to your database through pg admin. If so you can restore your database with below commands.

Gagea Alexandru
3/16/18, 6:02 AM

I go in /var/lib/odoo, to find the filestore, however, i dont have .local/share/Odoo folders...

inian
3/16/18, 6:07 AM

You cannot view this location in UI navigate through terminal

Gagea Alexandru
3/16/18, 6:51 AM

i was not in root mode, im in the filestore location, basically i want to restore a database on another server.

Tell me if the bellow steps are wrong:

1. backup database from pgadmin, production server

2. restore database in pgadmin on a development server

3.copy filestore from production server to the dev server.

inian
3/16/18, 6:58 AM

You are right but we cannot copy the file store from ./local/share/ folder. I already tried that.

inian
3/16/18, 7:00 AM

For your information, only images and icons are stored in file store.

Gagea Alexandru
3/16/18, 7:23 AM

i was able to copy the db filestore from that location, into the same location on another server, however, cannot acces the database from UI..

inian
3/16/18, 8:13 AM

how did you copy the file store. Share command. In order to work database name and file store name should be exactly same.

Gagea Alexandru
3/16/18, 8:33 AM

1. sudo -su root

2. cd /var/lib/odoo.local/share/Odoo/filestore

3. cp -R dbname /opt/Downloads

( to give write/read/delete permissions on the folder Downloads :

sudo chmod -R ugo+rw /opt/downloads )

4. Copied the filestore from server1(downloads) to server2 (downloads) and on server 2, used the cp command to copy from downloads back to filestore location, and yes it had the same name.

To transfer files from linux server to my desktop i use a program called WinSCP.

Gagea Alexandru
3/16/18, 8:50 AM

I solved my backup issue. Yesterday, i created 2 tables in the database, directly from pgadmin. This was the issue because backup from UI is made based on some scripts...So.. advice, if you want to create new tables in the database, its best if you create them from Studio. Thank you for your time and answers.

inian
3/19/18, 1:34 AM

Hi Gagea, in my case file store is stored in ./local/share.. you say you have copied the files form var/lib..

Files are not created for me in that folder

how did you install odoo. I followed following link.

https://www.rosehosting.com/blog/install-odoo-11-on-ubuntu-16-04/

you also say we must create table from studio. Do you mean the UI?

Gagea Alexandru
3/19/18, 4:00 AM

Yes, the full path of my filestore is :

cd /var/lib/odoo/.local/share/Odoo/filestore , and you must be in root mode in able to see this location ( sudo -su root ).

I installed Odoo 11 from Odoo.com installation docs.

Gagea Alexandru
3/19/18, 4:02 AM

And when i say studio, yes, its from the UI, available on Odoo Enterprise.

0
Sunny Dev
2/10/18, 1:00 AM

hi,


first you go into your filestore directory, and existing directory copy and paste with new db name.

in your case,

  • now you first delete created automatically Filestore folder in directory.

    • cd  ./local/share/Odoo/filestore/

    • apply command ==>  sudo rm -R rck_test6

  • after  that copy existing filestore db and paste with new name.

    • sudo cp -R  rck_test5 rck_test6


    after restart your server and check, all icons and images are displayed same as old db.


I hope it will help you.


Thanks



5 Comments
inian
2/12/18, 2:05 AM

Hi Sunny,

Thanks for your response, but I cannot copy or paste into ./local/share/Odoo/filestore/

Remove "rm" works but no other command works.

Sunny Dev
2/12/18, 5:08 AM

can you tried with "sudo" command?

inian
2/12/18, 5:20 AM

Tried that too, I don't get any errors.nothing can be copied from there. Some how odoo can write or copy when we take backup/restore from UI.

Sunny Dev
2/12/18, 6:09 AM

not sure, but it maybe comes from "web" module for backup via UI.

inian
2/12/18, 7:16 AM

My concern is it is ok to backup a small database using web UI. But can same be used for backing up a database that is large.

Ask a Question
Writer
Keep Informed
1 follower(s)
About This Community

This platform is for beginners and experts willing to share their Odoo knowledge. It's not a forum to discuss ideas, but a knowledge base of questions and their answers.

Register
Odoo Training Center

Access to our E-learning platform and experience all Odoo Apps through learning videos, exercises and Quizz.

Test it now