Odoo Help

Welcome!

This community is for beginners and experts willing to share their Odoo knowledge. It's not a forum to discuss ideas, but a knowledge base of questions and their answers.

0

AttributeError: 'NoneType' object has no attribute 'fields_view_get' [Closed]

By
charlesraj
on 10/30/13, 2:25 AM 10,024 views

The Question has been closed

by
Sudhir Arya (SA)
on 04/16/2014 02:29:51

When i tried to install the insurance module(migrated from version 6.0 to 7.0) The following error occured

The server-log file say

Traceback (most recent call last):


 File "/opt/openerp/server/openerp/addons/base/ir/ir_ui_view.py", line 126, in _check_render_view
    fvg = self.pool.get(view.model).fields_view_get(cr, uid, view_id=view.id, view_type=view.type, context=context)
AttributeError: 'NoneType' object has no attribute 'fields_view_get'
2013-10-30 08:56:27,913 1687 ERROR final openerp.tools.convert: Parse error in /opt/openerp/server/openerp/addons/insurance/insurance_view.xml:5: 

<record id="view_insurance_contract_refuse_reason_wizard_form" model="ir.ui.view">
        <field name="name">insurance.contract.refuse.reason.wizard.form</field>
        <field name="model">insurance.contract.refuse.reason.wizard</field>
      <!--  <field name="type">form</field>-->
        <field name="arch" type="xml">
            <form string="Refuse Reason" col="2" version="7.0">
                <label string="Please give a reason why you want to refuse this contract" align="0" colspan="2"/>
                <field name="reason" nolabel="1" colspan="2"/>
                <group colspan="2" col="2">
                    <button type="special" special="cancel" string="Cancel" icon="gtk-cancel"/>
                    <button type="object" name="action_confirm" string="Confirm"/>
                </group>
            </form>
        </field>
    </record>

.How can be solve this.

2

Sudhir Arya (SA)

--Sudhir Arya (SA)--
10150
| 6 8 8
Ahmedabad, India
--Sudhir Arya (SA)--

Working as an OpenERP/Odoo developer and a Team Leader 

Top 5 Odoo contributor On Stackoverflow

LinkedIn

Blog

Stackoverflow

Sudhir Arya (SA)
On 10/30/13, 6:11 AM

This type of error occurred when object defined in .py is not created due to some reason.

  1. Check that you have imported your .py in __init__.py.

  2. Check that class is properly closed or no, if you are using v6.0 or v6.1.

  3. Have you correctly defined _name and inherited osv.osv or not.

Hope this will solve your problem.

hi now this error occurs while click on install button can u please explain what this

charlesraj
on 10/30/13, 7:23 AM

Exception: Module loading failed: file insuranceses/insuranceses/security/ir.model.access.csv could not be processed: Line 1 : No matching record found for external id 'insurance.group_insurance_manager' in field 'Group'

charlesraj
on 10/30/13, 7:23 AM

For temporary comment insuranceses/insuranceses/security/ir.model.access.csv file from __openerp__.py file and try to install again. I guess your object is not getting created that is why you are facing this error.

Sudhir Arya (SA)
on 10/30/13, 8:58 AM

ok thats problem is solved by changing the group name. then again another error ValueError: No such external ID currently defined in the system: insurance.seq_insurance_expert_report

charlesraj
on 10/30/13, 9:49 AM

hi Sudhir Arya.. Finally i solved the issue and installed the module.. But in view page there is a parse error occured ... I just comment that field , but it will not affect the module functionlity in the primary testing i had done .. will you please mention what this parse error specifies..

charlesraj
on 10/31/13, 4:23 AM
3
Ani V
On 12/31/13, 2:00 AM

One possibility is dependency specified in the __openerp__.py file is wrong . Check for all module dependencies .

About This Community

This community is for professionals and enthusiasts of our products and services. Read Guidelines

Question tools

0 follower(s)

Stats

Asked: 10/30/13, 2:25 AM
Seen: 10024 times
Last updated: 3/16/15, 8:10 AM