Odoo Help

Welcome!

This community is for beginners and experts willing to share their Odoo knowledge. It's not a forum to discuss ideas, but a knowledge base of questions and their answers.

1

AttributeError: Field `sel_groups_19` does not exist

By
Drees Far
on 10/17/15, 8:57 AM 760 views

Hi everybody!!!

Please guys, is here somebody who knows the reason of this error.

here is what i have got in the terminal:

2015-10-17 12:53:15,878 6011 ERROR odoo openerp.addons.base.ir.ir_ui_view: Field `sel_groups_19` does not exist

Error context:

View `res.users.form`

[view_id: 153, xml_id: base.view_users_form, model: res.users, parent_id: n/a]

2015-10-17 12:53:15,879 6011 ERROR odoo openerp.http: Exception during JSON request handling.

Traceback (most recent call last):

File "/opt/odoo/odoo/openerp/http.py", line 536, in _handle_exception

return super(JsonRequest, self)._handle_exception(exception)

File "/opt/odoo/odoo/openerp/http.py", line 573, in dispatch

result = self._call_function(**self.params)

File "/opt/odoo/odoo/openerp/http.py", line 309, in _call_function

return checked_call(self.db, *args, **kwargs)

File "/opt/odoo/odoo/openerp/service/model.py", line 113, in wrapper

return f(dbname, *args, **kwargs)

File "/opt/odoo/odoo/openerp/http.py", line 306, in checked_call

return self.endpoint(*a, **kw)

File "/opt/odoo/odoo/openerp/http.py", line 802, in __call__

return self.method(*args, **kw)

File "/opt/odoo/odoo/openerp/http.py", line 402, in response_wrap

response = f(*args, **kw)

File "/opt/odoo/odoo/addons/web/controllers/main.py", line 937, in call_kw

return self._call_kw(model, method, args, kwargs)

File "/opt/odoo/odoo/addons/web/controllers/main.py", line 929, in _call_kw

return getattr(request.registry.get(model), method)(request.cr, request.uid, *args, **kwargs)

File "/opt/odoo/odoo/openerp/api.py", line 241, in wrapper

return old_api(self, *args, **kwargs)

File "/opt/odoo/odoo/openerp/models.py", line 1544, in fields_view_get

xarch, xfields = View.postprocess_and_fields(cr, uid, self._name, etree.fromstring(result['arch']), view_id, context=ctx)

File "/opt/odoo/odoo/openerp/api.py", line 241, in wrapper

return old_api(self, *args, **kwargs)

File "/opt/odoo/odoo/openerp/addons/base/ir/ir_ui_view.py", line 844, in postprocess_and_fields

self.raise_view_error(cr, user, message, view_id, context)

File "/opt/odoo/odoo/openerp/api.py", line 241, in wrapper

return old_api(self, *args, **kwargs)

File "/opt/odoo/odoo/openerp/addons/base/ir/ir_ui_view.py", line 369, in raise_view_error

raise AttributeError(message)

AttributeError: Field `sel_groups_19` does not exist

Regards.

Sorry but i havent modified code. Here are links you can understand. http://zupimages.net/viewer.php?id=15/42/8dra.png http://zupimages.net/viewer.php?id=15/42/22hn.png http://zupimages.net/viewer.php?id=15/42/bx81.png

Drees Far
on 10/17/15, 10:53 AM

could you please tell me what changes you made, and when you are getting this error?

Baiju
on 10/17/15, 11:32 AM

I have added a new group and in this group i gave him in the configuration of menu: Configuration, Configuration/Users; Configuration/Users/Users when i connect with the user of that group i got the menu configuration/user/user and when i click on create the user i got the error

Drees Far
on 10/17/15, 11:57 AM

if possible please include that code in question.

Baiju
on 10/17/15, 12:11 PM

Here are links: ----http://zupimages.net/viewer.php?id=15/42/8dra.png ----http://zupimages.net/viewer.php?id=15/42/22hn.png ----http://zupimages.net/viewer.php?id=15/42/bx81.png

Drees Far
on 10/17/15, 12:23 PM

you will find some images please follow those links

Drees Far
on 10/17/15, 12:23 PM

hey friend you still here or what????

Drees Far
on 10/17/15, 1:43 PM

did you only made changes from front-end ??

Baiju
on 10/18/15, 6:30 AM

i have created a new group and gave it the right as in administration/configuration but only to create users. I found the menu in the account of the user but when i click on create i have this error. Would you please follow the links that i have gave to understand or if you want try to explain to me how to add the right to create users or how to create the group that will create users please

Drees Far
on 10/18/15, 11:47 AM
0

Baiju

--Baiju--
3154
| 5 4 8
Kochi, India
--Baiju--
ODOO technical and functional

        I like learning new thing, especially technical thing. I am a quick learner, I can learn technical things very fast. I have good logical skill,  I have immense interest in programming.

e-mail id : baijuks@hotmail.com

Baiju
On 10/17/15, 9:12 AM

Hi, [Answer Updated]

Reason for this error is, instead of giving the group id or any attribute you just given a non-existent id or name.

from this (sel_groups_19) name it looks like the name of Application access right category( .ie name you when you hover mouse pointer over Application Access rights when developer mode is activated). You cant refer that name anywhere in code, because it changes when you add groups to that category, that name is generated according to groups in category.

Try removing that name from code and add the relevant group instead.

Hope this helps.

Thanks a lot for the answer but i have not defined this field named "sel_groups_19" and this error has come when i have defined a group allowing it to create new users pffffffffffff please help me if you can

Drees Far
on 10/17/15, 9:21 AM

I updated the Answer, please check now, hope this helps.

Baiju
on 10/17/15, 10:29 AM

Your Answer

Please try to give a substantial answer. If you wanted to comment on the question or answer, just use the commenting tool. Please remember that you can always revise your answers - no need to answer the same question twice. Also, please don't forget to vote - it really helps to select the best questions and answers!

About This Community

This community is for professionals and enthusiasts of our products and services. Read Guidelines

Question tools

1 follower(s)

Stats

Asked: 10/17/15, 8:57 AM
Seen: 760 times
Last updated: 11/21/15, 6:12 AM