Odoo Help


This community is for beginners and experts willing to share their Odoo knowledge. It's not a forum to discuss ideas, but a knowledge base of questions and their answers.


An error occurred while handling a json request

on 11/6/13, 5:43 AM 3,010 views

Hello, I tried to install a module webkit. The install worked normally (it's not the first time that i used webkit), but when i tried to print the concerned document, i had an error like that "pas de moteur webkit" (it's not exactly that, but it's that the meaning). Then when i refreshed the page i had that error: openerp.addons.web.http.HttpRequest.dispatch: An error occurred while handling a json request Traceback (most recent call last): File "/home/aymen/tfi_workspace/openerp-7.0/openerp/addons/web/http.py", line 285, in dispatch r = method(self, **self.params) File "/home/aymen/tfi_workspace/openerp-7.0/openerp/addons/web/controllers/main.py", line 675, in qweb content, checksum = concat_xml(files) File "/home/aymen/tfi_workspace/openerp-7.0/openerp/addons/web/controllers/main.py", line 255, in concat_xml xml = ElementTree.parse(fp).getroot() File "/usr/lib/python2.7/xml/etree/ElementTree.py", line 1183, in parse tree.parse(source, parser) File "/usr/lib/python2.7/xml/etree/ElementTree.py", line 656, in parse parser.feed(data) File "/usr/lib/python2.7/xml/etree/ElementTree.py", line 1643, in feed self._raiseerror(v) File "/usr/lib/python2.7/xml/etree/ElementTree.py", line 1507, in _raiseerror raise err ParseError: not well-formed (invalid token): line 21, column 1

Now, i can never open the openerp and i have always that error. Please, could you help me?


On 11/6/13, 5:56 AM

It's ok, the error has been fixed. I just had an error in base.xml in web module.

Dear, I have same error with you. So have you fixed this error in base.xml ? Thanks

on 3/29/14, 1:13 AM
On 11/6/13, 10:02 AM

It might be related to Werkzeug library. Check if it is installed, and which version it is. Version 0.8.3 works fine, with later versions I have had similar errors.

I do not guarantee this is the problem, but check it out, it might be that.

Thank you for your answer, but that didn't rsolve the problem.I have werkzeug installed, i tried also to make an update of werkzeug package but i have always the same error.

on 11/6/13, 10:40 AM

You are right. I had the same problem. https://pypi.python.org/pypi/Werkzeug/0.8.3

Josse Colpaert (jco)
on 11/21/13, 5:37 AM

Your Answer

Please try to give a substantial answer. If you wanted to comment on the question or answer, just use the commenting tool. Please remember that you can always revise your answers - no need to answer the same question twice. Also, please don't forget to vote - it really helps to select the best questions and answers!

About This Community

This community is for professionals and enthusiasts of our products and services. Read Guidelines

Question tools

0 follower(s)


Asked: 11/6/13, 5:43 AM
Seen: 3010 times
Last updated: 3/16/15, 8:10 AM