Odoo Help

Welcome!

This community is for beginners and experts willing to share their Odoo knowledge. It's not a forum to discuss ideas, but a knowledge base of questions and their answers.

0

all modules shows error when I try to install them

By
Afnan Mohammed
on 3/20/15, 5:55 PM 818 views

all the modules in my odoo 8 shows these errors when I try to download it :


Odoo Server Error Traceback (most recent call last): File "/home/afnan/Desktop/odoo-8.0/openerp/http.py", line 530, in _handle_exception return super(JsonRequest, self)._handle_exception(exception) File "/home/afnan/Desktop/odoo-8.0/openerp/http.py", line 567, in dispatch result = self._call_function(**self.params) File "/home/afnan/Desktop/odoo-8.0/openerp/http.py", line 303, in _call_function return checked_call(self.db, *args, **kwargs) File "/home/afnan/Desktop/odoo-8.0/openerp/service/model.py", line 113, in wrapper return f(dbname, *args, **kwargs) File "/home/afnan/Desktop/odoo-8.0/openerp/http.py", line 300, in checked_call return self.endpoint(*a, **kw) File "/home/afnan/Desktop/odoo-8.0/openerp/http.py", line 796, in __call__ return self.method(*args, **kw) File "/home/afnan/Desktop/odoo-8.0/openerp/http.py", line 396, in response_wrap response = f(*args, **kw) File "/home/afnan/Desktop/odoo-8.0/addons/web/controllers/main.py", line 953, in call_button action = self._call_kw(model, method, args, {}) File "/home/afnan/Desktop/odoo-8.0/addons/web/controllers/main.py", line 941, in _call_kw return getattr(request.registry.get(model), method)(request.cr, request.uid, *args, **kwargs) File "/home/afnan/Desktop/odoo-8.0/openerp/api.py", line 241, in wrapper return old_api(self, *args, **kwargs) File "/home/afnan/Desktop/odoo-8.0/openerp/addons/base/module/module.py", line 450, in button_immediate_install return self._button_immediate_function(cr, uid, ids, self.button_install, context=context) File "/home/afnan/Desktop/odoo-8.0/openerp/api.py", line 241, in wrapper return old_api(self, *args, **kwargs) File "/home/afnan/Desktop/odoo-8.0/openerp/addons/base/module/module.py", line 498, in _button_immediate_function registry = openerp.modules.registry.RegistryManager.new(cr.dbname, update_module=True) File "/home/afnan/Desktop/odoo-8.0/openerp/modules/registry.py", line 366, in new openerp.modules.load_modules(registry._db, force_demo, status, update_module) File "/home/afnan/Desktop/odoo-8.0/openerp/modules/loading.py", line 355, in load_modules loaded_modules, update_module) File "/home/afnan/Desktop/odoo-8.0/openerp/modules/loading.py", line 255, in load_marked_modules loaded, processed = load_module_graph(cr, graph, progressdict, report=report, skip_modules=loaded_modules, perform_checks=perform_checks) File "/home/afnan/Desktop/odoo-8.0/openerp/modules/loading.py", line 143, in load_module_graph load_openerp_module(package.name) File "/home/afnan/Desktop/odoo-8.0/openerp/modules/module.py", line 315, in load_openerp_module __import__('openerp.addons.' + module_name) File "/home/afnan/Desktop/odoo-8.0/openerp/modules/module.py", line 80, in load_module mod = imp.load_module('openerp.addons.' + module_part, f, path, descr) File "/home/afnan/Desktop/odoo-8.0/My_addons/Open_academy/__init__.py", line 1, in <module> import Course ImportError: No module named Course

0
Afnan Mohammed
On 3/21/15, 1:27 AM

I don't know how to cancel installation I just removed it from the folder and restarted the server .

I did that but the problem still the same :

I've tried creating anew database then I installed two of the existing modules , that worked fine , but after that I've opened the server using :

./odoo.py --addons-path addons,My_addons -u clinic -d test

it back the same and non of the modules were installabale  

0
Dr Obx
On 3/20/15, 6:29 PM

Apparently your Custom module is not finished or there is an error so:

0. "CANCEL INSTALLATION" of your Open Academy because is still active then delete it from the list of modules (just in case. You can always add it back updating list of modules)

1. restart server/service

2. check

3. remove your custom module (Open Academy)

4. restart server/service

5. should work fine :)

IMHO something is wrong with the Open Academy :)

Your Answer

Please try to give a substantial answer. If you wanted to comment on the question or answer, just use the commenting tool. Please remember that you can always revise your answers - no need to answer the same question twice. Also, please don't forget to vote - it really helps to select the best questions and answers!

About This Community

This community is for professionals and enthusiasts of our products and services. Read Guidelines

Question tools

2 follower(s)

Stats

Asked: 3/20/15, 5:55 PM
Seen: 818 times
Last updated: 3/21/15, 1:27 AM