Odoo Help

0

After restoring a db in OpenERP, it can't update the module list

By
Ehab Mosilhy
on 6/15/14, 6:42 AM 872 views
  • I took a backup of a db from a computer running windows 7 (using backup from the user interface which generated a dump file).

  • I then restored that database successfully on an Ubuntu machine from the user interface of OpeneERP.

  • I also copied the module which I'm working on into the addons directory.

  • The problem is that OpenERP can't update the module list, and in the installed modules menu it shows the old list of modules.

  • No matter how many times I restart the server and click on (Update Module List), the result is always the same, it can't see the module in the addons directory, even if I delete one of them from the directory or copy new ones, it shows the same modules list without change.

  • I created a new database beside the restored one, and the new database works fine, it can see the exact list of the addons directory and can feel any change of addition or delete.

  • I need to repeat that when creating new database, everything works fine, it can update module list and feel the changes in the addons directory, but the problem happens with restored db only, it can't feel any changes in the addons directory while the new db does.

What might be the problem?

About This Community

This platform is for beginners and experts willing to share their Odoo knowledge. It's not a forum to discuss ideas, but a knowledge base of questions and their answers.

Register

Odoo Training Center

Access to our E-learning platform and experience all Odoo Apps through learning videos, exercises and Quizz.

Test it now

Question tools

1 follower(s)

Stats

Asked: 6/15/14, 6:42 AM
Seen: 872 times
Last updated: 3/16/15, 8:10 AM