Odoo Help

0
3 Answers
1
Gregory Gillis
11/9/18, 12:17 PM

If you are trying to view a new module in the Apps module you can do these:

  1. Move the module folder into your addons folder

  2. Enter developer mode (Settings>Activate Developer Mode)

  3. Apps>Update Apps List

  4. Search for module name. Remove "apps" filter if not an app.

  5. If not visible, refresh your browser, then try again.

If you are making the module yourself, you can add the code below to your __manifest__.py file. You will need to refresh your Odoo server for the change to take affect.

    'sequence': 1,
This should put it as the first item in the apps module when the 'apps' filter is off. 

To view the module in the dashboard AFTER it is installed, you will need to make sure you have your permissions set properly. You can verify in the code of your module that you have permissions to read/write/create/delete by default, or you can modify in Settings>Users, or in Settings>Technical>Access Rights (in developer mode). Once you have proper permission, when you refresh your browser, it should appear.
0
abhiram
11/12/18, 1:14 AM

I am not able to comment on the answers for which you guys have provided I want to add/view my custom module here in the home dashboard not in the appList/moduleList. I mean here "http://localhost:8069/web#home".


0
Akshay
11/9/18, 4:28 AM

You have to add   "sequence"             :  1,  in the manifest.py of your custom module.

Sequence determines the position of your app in the apps dashboard. 


Ask a Question
Writer
Keep Informed
1 follower(s)
About This Community

This platform is for beginners and experts willing to share their Odoo knowledge. It's not a forum to discuss ideas, but a knowledge base of questions and their answers.

Register
Odoo Training Center

Access to our E-learning platform and experience all Odoo Apps through learning videos, exercises and Quizz.

Test it now