Odoo Help

Welcome!

This community is for beginners and experts willing to share their Odoo knowledge. It's not a forum to discuss ideas, but a knowledge base of questions and their answers.

2

Aeroo Reports: Error while generating the report [Closed]

By
Andrea Cometa
on 4/19/13, 8:30 AM 3,112 views

The Question has been closed

by
Sudhir Arya (SA)
on 04/21/2013 08:42:28

I'm getting this error, and I'm not able to find a solution...

OS: Debian Wheezy, OpenERP 7, LibreOffice, OpenJDK-7, PGSql 9.1, Aeroolib (everything installed as usual, except wheezy instead squeeze)

when I click on my print report button, I get this error:


Aeroo Reports: Error while generating the report "name of the report"

ascii
<office:document-content xmlns:office="urn:oasis:names:tc:opendocument:xmlns:office:1.0" xmlns:style="urn:oasis:names:tc:opendocument:xmlns:style:1.0" xmlns:text="urn:oasi...

...a lot of code...

...xt></office:body></office:document-content>
25017
25018
ordinal not in range(128)

Is there an "over 7 bit" char (so not ascii char) in your report?

TheBrush
on 4/19/13, 2:07 PM

Thank for your interest, no there are no "over 7 bit" char. (reports works perfectly on my developing notebook with ubuntu)

Andrea Cometa
on 4/19/13, 2:18 PM

Same error on Ubuntu Server 12.10 i386

Andrea Cometa
on 4/20/13, 7:16 AM
2

Serpent Consulting Services Pvt. Ltd.

--Serpent Consulting Services Pvt. Ltd.--
4341
| 6 6 8
Gandhinagar, India
--Serpent Consulting Services Pvt. Ltd.--

Serpent Consulting Services Pvt. Ltd. Your Odoo/OpenERP Solution, just an email away!

Serpent Consulting Services Pvt. Ltd.
On 4/19/13, 5:27 PM

I doubt about your Genshi version!

my Genshi version is 0.6-3

Andrea Cometa
on 4/20/13, 5:09 AM

now I'm on Genshi 0.7 (pip install genshi) but same error

Andrea Cometa
on 4/20/13, 7:03 AM

thanks, now with genshi == 0.6 all works fine

Andrea Cometa
on 4/21/13, 8:30 AM
2
Andrea Cometa
On 4/20/13, 8:30 AM

Forcing the installation of the Genshi 0.6 ("Genshi == 0.6"), all works fine.

I have the same problem in Ubuntu 12.04, this is the downgrade operation for Genshi (7 > 0.6): cd /usr/local/lib/python2.7/dist-packages/ sudo mv Genshi-0.7-py2.7-linux-x86_64.egg/ ~ # OR REMOVE DIRECTLY! sudo wget http://ftp.edgewall.com/pub/genshi/Genshi-0.6.1-py2.7.egg sudo easy_install Genshi-0.6-py2.7-linux-x86_64.egg sudo /etc/init.d/openerp-server restart

TheBrush
on 6/14/13, 9:47 AM

About This Community

This community is for professionals and enthusiasts of our products and services. Read Guidelines

Question tools

0 follower(s)

Stats

Asked: 4/19/13, 8:30 AM
Seen: 3112 times
Last updated: 3/16/15, 8:10 AM