Odoo Help


Administrator as default salesperson in list of sales quotations sort of breaks the “My”-View

Philipp Becker
on 9/30/15, 4:06 AM 1,355 views

In Sales -> Quotations there is a list of quotations. In my rather un-tuned System, the salesperson is always "Administrator".

Why is that? And can I change the default, if at all possible without programming?

The same thing goes for “sales orders”, of course.

The problem I would like to solve is, that my customer would like to see all orders and quotations, without first having to dismiss the „wrong“ filter called „My“.

He is manager in sales. And he is in the sales team that is responsible for the quotation. So why can he not see the items?

Is changing the default salesperson really the only way to get rid of this problem? I cannot seem to change this „My“-filter, nor does it seem to work the way it was intended. Maybe the user rights are not configured the right way?

The desired outcome is: The user logs into odoo, he clicks on “Sales”, he clicks on “Quotations” and all Quotations, from every salesperson, are displayed for him. After all, he is the sales manager.

The user rights currently attributed to this user are:

• Sales: Manager
• Accounting & Finance: Financial Manager
• Human Resources: Employee
• Discount on lines: check
• Manage Sales Teams: check
• Sales Pricelist: check
• Contact Creation: check
• Website Comments: check

It would be great, if someone could explain what is happening there and/or come up with a solution.

On 9/30/15, 4:56 AM

Go to Settings -> Technical -> Actions -> User-defined Defaults

Create -> Name = user_id | Model name = sale.order 

In the Default value you put in : False 

Now the administrator won't automatically set when creating an quotation/sale order. 

I don't think there is a way to disable the "my" filter without programming. Maybe somebody else knows this. 

Carlos A García
On 10/9/18, 5:54 PM

For me in Odoo 8 works this:

Settings/Users/Public user, configure inside the res.partner associated to this user the Salesperson you want to show by default in sales.orders from Web Site. If this field left blank, the Administrator is used instead by default.

About This Community

This platform is for beginners and experts willing to share their Odoo knowledge. It's not a forum to discuss ideas, but a knowledge base of questions and their answers.


Odoo Training Center

Access to our E-learning platform and experience all Odoo Apps through learning videos, exercises and Quizz.

Test it now

Question tools

1 follower(s)


Asked: 9/30/15, 4:06 AM
Seen: 1355 times
Last updated: 10/9/18, 5:54 PM