Odoo Help

Welcome!

This community is for beginners and experts willing to share their Odoo knowledge. It's not a forum to discuss ideas, but a knowledge base of questions and their answers.

0

Add Google Doc generates AttributeError: 'module' object has no attribute 'Resource'

By
Mike Lindsay
on 4/23/13, 8:37 PM 3,507 views

I installed the google docs and google integration modules. I setup my user profile with my google account. When I goto a task I own, and click on Add Google Doc, I generate this error;

OpenERP Server Error Client Traceback (most recent call last): File "/opt/openerp/7.0/prod/openerp/addons/web/http.py", line 203, in dispatch response["result"] = method(self, *self.params) File "/opt/openerp/7.0/prod/openerp/addons/web/controllers/main.py", line 1129, in call_kw return self._call_kw(req, model, method, args, kwargs) File "/opt/openerp/7.0/prod/openerp/addons/web/controllers/main.py", line 1121, in _call_kw return getattr(req.session.model(model), method)(args, **kwargs) File "/opt/openerp/7.0/prod/openerp/addons/web/session.py", line 43, in proxy result = self.proxy.execute_kw(self.session._db, self.session._uid, self.session._password, self.model, method, args, kw) File "/opt/openerp/7.0/prod/openerp/addons/web/session.py", line 31, in proxy_method result = self.session.send(self.service_name, method, *args) File "/opt/openerp/7.0/prod/openerp/addons/web/session.py", line 104, in send raise xmlrpclib.Fault(openerp.tools.ustr(e), formatted_info)

Server Traceback (most recent call last): File "/opt/openerp/7.0/prod/openerp/addons/web/session.py", line 90, in send return openerp.netsvc.dispatch_rpc(service_name, method, args) File "/opt/openerp/7.0/prod/openerp/netsvc.py", line 293, in dispatch_rpc result = ExportService.getService(service_name).dispatch(method, params) File "/opt/openerp/7.0/prod/openerp/service/web_services.py", line 626, in dispatch res = fn(db, uid, params) File "/opt/openerp/7.0/prod/openerp/osv/osv.py", line 188, in execute_kw return self.execute(db, uid, obj, method, *args, *kw or {}) File "/opt/openerp/7.0/prod/openerp/osv/osv.py", line 131, in wrapper return f(self, dbname, args, *kwargs) File "/opt/openerp/7.0/prod/openerp/osv/osv.py", line 197, in execute res = self.execute_cr(cr, uid, obj, method, args, *kw) File "/opt/openerp/7.0/prod/openerp/osv/osv.py", line 185, in execute_cr return getattr(object, method)(cr, uid, args, *kw) File "/opt/openerp/7.0/prod/openerp/addons/google_docs/google_docs.py", line 171, in google_doc_get google_document = pool_ir_attachment.create_empty_google_doc(cr, uid, res_model, res_id, context=context) File "/opt/openerp/7.0/prod/openerp/addons/google_docs/google_docs.py", line 97, in create_empty_google_doc local_resource = gdata.docs.data.Resource(gdata.docs.data.DOCUMENT_LABEL,title=title) AttributeError: 'module' object has no attribute 'Resource'

3
Santiago
On 4/27/13, 9:31 AM

I fix it in Ubuntu with:

apt-get remove python-gdata

apt-get install python-pip

pip install gdata --upgrade

this worked after a server reboot, ty Santiago!

Mike Lindsay
on 4/29/13, 3:40 PM

Thanks this worked for me as well. But a server reboot was not neccessary all I did was restart OpenERP with: $ sudo /etc/init.d/openerp-server restart

Jeff
on 10/7/13, 11:16 PM

Your Answer

Please try to give a substantial answer. If you wanted to comment on the question or answer, just use the commenting tool. Please remember that you can always revise your answers - no need to answer the same question twice. Also, please don't forget to vote - it really helps to select the best questions and answers!

About This Community

This community is for professionals and enthusiasts of our products and services. Read Guidelines

Question tools

0 follower(s)

Stats

Asked: 4/23/13, 8:37 PM
Seen: 3507 times
Last updated: 3/16/15, 8:10 AM