Odoo Help

Welcome!

This community is for beginners and experts willing to share their Odoo knowledge. It's not a forum to discuss ideas, but a knowledge base of questions and their answers.

0

Action Button: doesn't seem to work for some records... [Solved]

By
deep
on 10/6/14, 5:46 AM 763 views

In Invoice: Validate Button (action  called from workflow) doesn't seem to work for few records..

Any idea why it happens like this...

 

I tried refreshing the form, cancelling the record in vain, but just validate doesn't seem to work, I tried for other records it works fine.. any body have faced like this kind of issue

 

Can you describe the procedure when the "validate doesn't seem to work" exactly?

Ben Bernard
on 10/6/14, 6:06 AM
0

deep

--deep--
1617
| 5 4 7
Bengaluru, India
--deep--

Techno-Functional Associate with 6+ years of experience in Odoo (formerly known as OpenERP).

deep
On 10/28/14, 3:44 AM

Well finally I found the reason behind it, Workflow for that particluar record was not initiated.. 

My Scenario:
       I had inserted a couple of records from backend (PostgreSQL), hence for those records the Workflow was not initiated by default, So later when I established the call for workflow for those records, then everything [especially action buttons] works fine..!!

Code goes something like this..
       self.create_workflow(cr, uid, [ID])

Your Answer

Please try to give a substantial answer. If you wanted to comment on the question or answer, just use the commenting tool. Please remember that you can always revise your answers - no need to answer the same question twice. Also, please don't forget to vote - it really helps to select the best questions and answers!

About This Community

This community is for professionals and enthusiasts of our products and services. Read Guidelines

Question tools

2 follower(s)

Stats

Asked: 10/6/14, 5:46 AM
Seen: 763 times
Last updated: 3/16/15, 8:10 AM