Odoo Help


access rules for wizards

on 4/16/13, 3:00 PM 3,489 views


Is it possible to set a user-based access rules for wizards?


What do you exactly want to do ? Do you not want user to access that wizard or wizard menu should not be appear for that user ? Please share more information!

Priyesh Solanki (pso)
on 4/17/13, 3:15 AM

I want to hide some wizards menus from regular users

on 4/17/13, 3:43 AM

Ok, then you can create a Group, Assign that group to that wizard menus but do not assign that group to that regular user. It means that if that user has no group, user won't be able to see that wizard menu.

Priyesh Solanki (pso)
on 4/17/13, 3:47 AM

is it possible to set it in 'security\ir.model.access.csv' files?

on 4/17/13, 4:59 AM

No, with wizard, it will not work but you can hide some fields if you want by using attrs attribute!

Priyesh Solanki (pso)
on 4/17/13, 5:21 AM

Vasiliy Birukov

--Vasiliy Birukov--
| 7 6 8
Russian Federation
--Vasiliy Birukov--

Help develop and implement any project on base Odoo.

Vasiliy Birukov
On 4/17/13, 3:30 AM

Yes, you can set for user any access rules for any object.

You can make it by assign User to Group. See menu "Settings/Users". For Group you define access rules. See menu "Settings/Technical/Security/Access Controls List".

Do you think will it work for wizard?

Sudhir Arya (ERP Harbor Consulting Services)
on 4/17/13, 3:34 AM

Strangely, for wizard it don't work. I define access rules, that don't permit read. But it remained readable! So object-level permissions don't work for Transient Model?

Vasiliy Birukov
on 4/17/13, 4:26 AM

About This Community

This platform is for beginners and experts willing to share their Odoo knowledge. It's not a forum to discuss ideas, but a knowledge base of questions and their answers.


Odoo Training Center

Access to our E-learning platform and experience all Odoo Apps through learning videos, exercises and Quizz.

Test it now

Question tools

1 follower(s)


Asked: 4/16/13, 3:00 PM
Seen: 3489 times
Last updated: 3/16/15, 8:10 AM