Odoo Help

Welcome!

This community is for beginners and experts willing to share their Odoo knowledge. It's not a forum to discuss ideas, but a knowledge base of questions and their answers.

1

Access Rights to create new users

v7
By
Dwight Butler
on 3/14/13, 4:04 PM 4,347 views

I am currently running Version 7.0-20130314-002547 of openerp in a multicompany environment on debian 6. I am able to create users with the admin ID successfully. I create an ID that has the same rights as the admin ID, I log in with that user with the admin rights and create a new user but I get an error message "The requested operation cannot be completed due to security restrictions. Please contact your system administrator. (Document type: Users, Operation: create)" when I try to save the new user. I have looked at all the suggestions on this forum about users and rights and tried them but I am still unable to create and save new users as the new admin user I created. I have checked and unchecked the technical features box and made sure the new admin user has Users/Administration/Settings rights.

3

Fabien Pinckaers (fp)

--Fabien Pinckaers (fp)--
6598
| 6 8 8
fsdsdfsdf, Belgium
--Fabien Pinckaers (fp)--

Odoo Founder & CEO

Fabien Pinckaers (fp)
On 3/14/13, 6:29 PM

If it does not work when your user is in the group Administration/Settings, it's probably because you changed the default access rights rules. Normally, it should work out-of-the-box, unless you changed the access rights rules.

You can investigate by checking this:

  • set the admin user in the group "Technical Features"
  • reload to get all menus
  • Go to the menu Settings/Users/Groups
  • Check the group Administration / Access Rights
  • In the "Access Rights" tab of this group, you should see a line with object Users having "Create Access" checked
  • Then, check the group "Administration / Settings"
  • In the "Inherited" tab, you should see a line with Group Name "Access Rights".

The settings for both the groups are exactly as stated in your post and the admin user I created is also listed under the users tab in both groups. I tried creating a blank dummy database by chance thinking I had a corrupt database but I still have the same problem when saving a new user while logged in with the admin user ID that I create. Could it be related to the version of PostgreSQL 9.1 that I am running? I am at a total lost as now I am experiencing the same problem with Ubuntu 12.10 and Debian 6.

Dwight Butler
on 3/14/13, 7:26 PM

i can confirm this, with fresh installation errors happens 6.1, 7.0

Cristian Salamea
on 10/15/13, 2:16 PM
0

Kevin McMenamin

--Kevin McMenamin--
804
| 5 2 6
Auckland, New Zealand
--Kevin McMenamin--
Kevin McMenamin
On 3/14/13, 4:24 PM

The setting you need to look at is in the user - make sure Administration is set to Settings for the user who will be creating new users.

The new admin user ID has Users/Administration/Settings rights but still gets error message on save.

Dwight Butler
on 3/14/13, 4:31 PM
0
Cristian Salamea
On 10/15/13, 2:16 PM

i can confirm this, with fresh installation errors happens 6.1, 7.0

I have the same problem: it seems there is no way to create new user not from user with id=1 (admin)

yustas77
on 11/18/13, 3:54 AM
0
vim24
On 3/17/13, 5:25 PM

Potentially this bug: bugs.launchpad.net/openobject-server/+bug/1021378. Try updating to the latest version, as a fix has supposedly just been released.

Your Answer

Please try to give a substantial answer. If you wanted to comment on the question or answer, just use the commenting tool. Please remember that you can always revise your answers - no need to answer the same question twice. Also, please don't forget to vote - it really helps to select the best questions and answers!

About This Community

This community is for professionals and enthusiasts of our products and services. Read Guidelines

Question tools

2 follower(s)

Stats

Asked: 3/14/13, 4:04 PM
Seen: 4347 times
Last updated: 3/16/15, 8:10 AM