Odoo Help

5
2 Answers
2
Avatar

Grover Hernando Menacho Quisbert

--Grover Hernando Menacho Quisbert--
WebVision Enterprise Systems
https://www.linkedin.com/in/hmen89/
2903
| 6 8 8
La Paz, Bolivia
--Grover Hernando Menacho Quisbert--

Odoo Developer

Grover Hernando Menacho Quisbert
4/29/14, 2:34 PM

You've to assign the parent company to your user. This rule says that:

Name: Location multi-company
Object: Location
Rule: ['|',('company_id','=',False),('company_id','child_of',[user.company_id.id])]

So, you've to give the main company to the user, or, you've to remove or change the rule:

Settings>Technical>Security>Record Rules
1 Comment
Elephante, Sean Samborski
9/25/14, 7:06 PM

Multi-company is so buggy in OpenERP. The only way I have ever gotten this to work is remove the rule. On each and every instance I install OpenERP it will not work unless I remove this rule. Even giving the parent company (which is not ideal) to the user does not allow this to work.

0
Avatar

Med Said BARA

--Med Said BARA--

2814
| 5 5 7
Algeria
--Med Said BARA--
Med Said BARA
4/29/14, 2:14 PM

Under Users Configuration, verify the following access rights for the user1:

Multi Company (Usability)

Manage Multiple Locations and Warehouses (Technical Settings)

And the Allowed Companies

Ask a Question
Writer
5637
Remya
Keep Informed
0 follower(s)
About This Community

This platform is for beginners and experts willing to share their Odoo knowledge. It's not a forum to discuss ideas, but a knowledge base of questions and their answers.

Register
Odoo Training Center

Access to our E-learning platform and experience all Odoo Apps through learning videos, exercises and Quizz.

Test it now