Odoo Help


This community is for beginners and experts willing to share their Odoo knowledge. It's not a forum to discuss ideas, but a knowledge base of questions and their answers.


Access Denied (Document type: Partner, Operation: write)

Lakay lakay
on 9/23/14, 11:56 PM 3,060 views


I created a new module and this module lets you to edit record in the "res.partners" table/object. 

I created a new user and give it the right to access "portal"

when i logged in as the new user and itry to click a button that lets you to edit record in the "res.partners" then it throws an error.

Access Denied

The requested operation cannot be completed due to security restrictions. Please contact your system administrator.

(Document type: Partner, Operation: write)             

anyone encountered and solved this ?






Mariusz Mizgier
On 9/24/14, 1:11 PM

Check Record Rules, especially Portal Personal Contacts and res_partner: read access on my partner

when using administrator account, i go to settings >>Technical >> security >> record rules i already given full access rights (R,W,C,D) to the Portal Personal Contacts with the ff domain filter of ([('message_follower_ids','in',[user.partner_id.id])] and the same with the res_partner res_partner: portal/public: read access on my commercial partner with domain filter of ([('id', 'child_of', user.commercial_partner_id.id)])

Lakay lakay
on 9/24/14, 8:45 PM

but still the same error, i actually try to give all access control list to my new account but same as the administrator, but still error.

Lakay lakay
on 9/24/14, 8:46 PM

Try deactivating them.

Currenda Sp. z o.o., Mariusz Mizgier
on 9/25/14, 1:21 AM

@ Mariusz Mizgier , deactivate the given access rights same as the admin? already did that and same error still.....

Lakay lakay
on 9/25/14, 4:21 AM

is this a bug? what do you think?

Lakay lakay
on 9/25/14, 4:27 AM

I would first try to look in the log for information, why this access denied error occured - you should have it stated if it is related to record rules or access record list - get this error, look up in the log and if you can't trace it, post the output here.

Currenda Sp. z o.o., Mariusz Mizgier
on 9/25/14, 4:41 AM

[Solved] I just uninstall the module and install it again. Whheeeewww.. btw thanks Mariusz!

Lakay lakay
on 9/25/14, 11:14 PM

Atchuthan - Technical Consultant, Sodexis Inc

--Atchuthan - Technical Consultant, Sodexis Inc--
| 5 3 8
Puducherry, India
--Atchuthan - Technical Consultant, Sodexis Inc--
Passionate coder in Python/Odoo(formerly known as OpenERP).

Contact me via GMail: atchuthantu@gmail.com via Skype: atchuthan_skype
via Linkedin: http://in.linkedin.com/in/atchuthantu
Atchuthan - Technical Consultant, Sodexis Inc
On 9/24/14, 2:37 AM

For portal user, the access rights provided for res.partner table is 
Read - False
Create - False
Write - False
Delete - False

If need access to write, create and read.  Please enable "Contact Creation" group for that particular user.

still getting the same error, i already enabled the Contact Creation for the particular user.

Lakay lakay
on 9/24/14, 2:57 AM

Your Answer

Please try to give a substantial answer. If you wanted to comment on the question or answer, just use the commenting tool. Please remember that you can always revise your answers - no need to answer the same question twice. Also, please don't forget to vote - it really helps to select the best questions and answers!

About This Community

This community is for professionals and enthusiasts of our products and services. Read Guidelines

Question tools

2 follower(s)


Asked: 9/23/14, 11:56 PM
Seen: 3060 times
Last updated: 3/16/15, 8:10 AM