Odoo Help

Welcome!

This community is for beginners and experts willing to share their Odoo knowledge. It's not a forum to discuss ideas, but a knowledge base of questions and their answers.

0

[8.0] Update Modules List - Not working via command line or Settings->Update Modules button

By
John
on 12/19/14, 8:23 AM 3,221 views

I'm trying to have odoo update the list of modules from the addons directory because I created a new module. 

I created the new module using the following command:

./odoo.py scaffold addons/module_name

I added an xml file to inherit a view, and added that file to the __openerp__.py

I went to my running instance, and went to Settings -> Update Module List.  I got the following warning:

Warning - Cannot execute name_search, no _rec_name defined on base.module.update

and could not find my module in the list.

I tried the command listed here: https://www.odoo.com/forum/help-1/question/is-update-module-list-from-command-line-possible-54578

but I received another warning:

openerp.modules.loading: invalid module names, ignored: module_name

I've confirmed that I am typing the correct directory name for the module name. 

I used the correct --addons-path variable when I ran the command line. 

Does anyone have any other ideas on what I can do to make my module show up in the list?

0
John
On 12/19/14, 11:50 AM

I found out my error.  I had edited the __openerp__.py file and there was a syntax error. 

I forgot a comma after the line

'summary': """summary/description"""

should have been

'summary': """summary/description""",

I'm surprised that odoo didn't throw an error or an exception, but at least it's working!

0
Juan Carlos
On 12/19/14, 11:21 AM

Definitely start in Odoo is a small headache.

When you go to update a module verify that is not initiated the process of Odoo.

Ok you can use in the odoo file

./openerp-server --help

And you can look at the list the commands of server. The second or third command is

-u UPDATE, --update=module

This is an example to use.

./openerp-server -u UPDATE, --update=nameOfYourModule -d nameOfDatabase

To upgrade all modules

./openerp-server -u UPDATE, --update=all -d nameOfDatabase

My personal example

./openerp-server -u UPDATE, --update=openacademy -d naro

You can use ./odoo.py instead of ./openerp-server I think it's the same.

Your Answer

Please try to give a substantial answer. If you wanted to comment on the question or answer, just use the commenting tool. Please remember that you can always revise your answers - no need to answer the same question twice. Also, please don't forget to vote - it really helps to select the best questions and answers!

About This Community

This community is for professionals and enthusiasts of our products and services. Read Guidelines

Question tools

1 follower(s)

Stats

Asked: 12/19/14, 8:23 AM
Seen: 3221 times
Last updated: 3/16/15, 8:10 AM