Odoo Help


This community is for beginners and experts willing to share their Odoo knowledge. It's not a forum to discuss ideas, but a knowledge base of questions and their answers.


[8.0] 'TypeError: openerp.init is not a function' after logging in

Ryan Cole
on 12/7/15, 9:10 PM 392 views

I'm running a production instance of Odoo for my company, and at some point today Odoo seems to have died and will no longer present the main menu. The database manager/selector/login screens, but I cannot see anything from the main Odoo UI (messages, sales, settings, etc).

As far as I can tell, there was no reboot/crash that caused the issue. I have tried to access our server from multiple different OSs, PCs, and browsers. I've also tried backing up, dropping, and restoring the database(s). Nothing so far has made a difference.

This is extremely important as our business relies 100% on Odoo's functionality, and right now we have no way of selling products.

Server details:
  - Odoo 8.0
  - Ubuntu Trusty 14.04
  - nginx 1.4.6

Any help is greatly appreciated.

Ryan Cole
On 7/28/16, 3:45 AM

Update for posterity:

This error was fixed by disabling Firefox's strict mixed-content settings for HTTPS wbesites. I'd be willing to bet that a similar option is present on Chrome/Safari/etc.


Your Answer

Please try to give a substantial answer. If you wanted to comment on the question or answer, just use the commenting tool. Please remember that you can always revise your answers - no need to answer the same question twice. Also, please don't forget to vote - it really helps to select the best questions and answers!

About This Community

This community is for professionals and enthusiasts of our products and services. Read Guidelines

Question tools

1 follower(s)


Asked: 12/7/15, 9:10 PM
Seen: 392 times
Last updated: 7/28/16, 3:45 AM