Odoo Help

1

500 Internal Server Error while opening LocalHost:8069

By
Ahmad Abdat
on 10/14/16, 11:08 PM 2,220 views

Ahoy Fellas,

My name is Ahmad Abdat From Indonesia, now i am a student at Pancasila University.

I have trouble when accessing the LocalHost:8069, even though I already install the Odoo Application in my Laptop.

My Laptop specs is Windows 7 with processor AMD E1-25-- APU with Radeon(TM) HP Graphics 1.40 GHz, installed memory (RAM) 2.00GB with system type 64-bit Operating System.


mean while, I have tried to search the solution about this problem with google, but none of the resume that exist in google could solve it or match with my laptop specification.


Please kindly help me with this problem. I would like to thank you so much for helping me.


Thank You, Good Luck Everyone


Warm Regards,

Ahmad

You should provide the log entries in order to get help.

Ermin Trevisan
on 10/15/16, 2:46 AM

make sure you have installed all the required library properly. in order to see which is missing go inside log and check.

Prince Caspion
on 10/15/16, 2:48 PM

What is Odoo's version?

Artem
on 10/16/16, 3:23 PM

Thank you Ermin and Prince Caspion for your advice, I'll try it

Artem: Odoo8 version, please another advice from you thank you

Ahmad Abdat
on 10/17/16, 11:14 AM
0
Emad
On 1/30/18, 5:36 AM

Also when open give me 500 error and the details in log file :

2018-01-30 10:22:24,376 9672 INFO ? odoo.sql_db: Connection to the database failed

2018-01-30 10:22:24,378 9672 INFO ? werkzeug: 127.0.0.1 - - [30/Jan/2018 10:22:24] "GET /favicon.ico HTTP/1.1" 500 -

2018-01-30 10:22:24,384 9672 ERROR ? werkzeug: Error on request:

Traceback (most recent call last):

File "C:\Program Files (x86)\Odoo 11.0\python\lib\site-packages\werkzeug\serving.py", line 209, in run_wsgi

execute(self.server.app)

File "C:\Program Files (x86)\Odoo 11.0\python\lib\site-packages\werkzeug\serving.py", line 197, in execute

application_iter = app(environ, start_response)

File "C:\Program Files (x86)\Odoo 11.0\server\odoo\service\server.py", line 252, in app

return self.app(e, s)

File "C:\Program Files (x86)\Odoo 11.0\server\odoo\service\wsgi_server.py", line 166, in application

return application_unproxied(environ, start_response)

File "C:\Program Files (x86)\Odoo 11.0\server\odoo\service\wsgi_server.py", line 154, in application_unproxied

result = handler(environ, start_response)

File "C:\Program Files (x86)\Odoo 11.0\server\odoo\http.py", line 1306, in __call__

return self.dispatch(environ, start_response)

File "C:\Program Files (x86)\Odoo 11.0\server\odoo\http.py", line 1269, in __call__

return self.app(environ, start_wrapped)

File "C:\Program Files (x86)\Odoo 11.0\python\lib\site-packages\werkzeug\wsgi.py", line 600, in __call__

return self.app(environ, start_response)

File "C:\Program Files (x86)\Odoo 11.0\server\odoo\http.py", line 1435, in dispatch

self.setup_db(httprequest)

File "C:\Program Files (x86)\Odoo 11.0\server\odoo\http.py", line 1367, in setup_db

httprequest.session.db = db_monodb(httprequest)

File "C:\Program Files (x86)\Odoo 11.0\server\odoo\http.py", line 1518, in db_monodb

dbs = db_list(True, httprequest)

File "C:\Program Files (x86)\Odoo 11.0\server\odoo\http.py", line 1486, in db_list

dbs = odoo.service.db.list_dbs(force)

File "C:\Program Files (x86)\Odoo 11.0\server\odoo\service\db.py", line 366, in list_dbs

with closing(db.cursor()) as cr:

File "C:\Program Files (x86)\Odoo 11.0\server\odoo\sql_db.py", line 634, in cursor

return Cursor(self.__pool, self.dbname, self.dsn, serialized=serialized)

File "C:\Program Files (x86)\Odoo 11.0\server\odoo\sql_db.py", line 178, in __init__

self._cnx = pool.borrow(dsn)

File "C:\Program Files (x86)\Odoo 11.0\server\odoo\sql_db.py", line 517, in _locked

return fun(self, *args, **kwargs)

File "C:\Program Files (x86)\Odoo 11.0\server\odoo\sql_db.py", line 585, in borrow

**connection_info)

File "C:\Program Files (x86)\Odoo 11.0\python\lib\site-packages\psycopg2\__init__.py", line 130, in connect

conn = _connect(dsn, connection_factory=connection_factory, **kwasync)

psycopg2.OperationalError: FATAL: no pg_hba.conf entry for host "172.16.11.83", user "openpg", database "postgres", SSL off

-----------------------------

0

Cameron

--Cameron--

1121
| 6 5 8
United Kingdom
--Cameron--
Cameron
On 1/30/18, 4:32 AM

(this is for a Linux install NOT Windows - however there may be clues to a solution)

In command prompt

sudo systemctl start odoo10.service (or as appropriate)

then

journalctl -xe

My issue was the rights access issue the top level directory /opt/odoo was owned by Mr Root

a quick 

sudo chmod odoo:root /opt/odoo -R

= happy days


0
Johannes
On 11/21/16, 2:44 AM

Install Again with Not Antivirus Running

0
Artem
On 10/16/16, 3:58 PM

Please check https://www.odoo.com/forum/help-1/question/version-10-0-localhost-refused-to-connect-109368#answer-109376

About This Community

This platform is for beginners and experts willing to share their Odoo knowledge. It's not a forum to discuss ideas, but a knowledge base of questions and their answers.

Register

Odoo Training Center

Access to our E-learning platform and experience all Odoo Apps through learning videos, exercises and Quizz.

Test it now

Question tools

1 follower(s)

Stats

Asked: 10/14/16, 11:08 PM
Seen: 2220 times
Last updated: 1/30/18, 5:36 AM