Odoo Help

1

403 (Forbidden) Response on Google Maps API in contact form

By
Demian Rihs
on 8/18/16, 8:36 PM 649 views

Hi,

I can't see the map thumbnail in my contact form anymore. I just see a missing image icone although the link is working. In my Browser console I get this error message

GET http://maps.googleapis.com/maps/api/staticmap?sensor=false&zoom=8&center=Via+Pratocarasso+56%2C+Bellinzona+6500%2C+Svizzera&size=298x298 403 (Forbidden)


I am using nginx to redirect all the web traffic from port 80 to 8069 and all links that are "company.com" to "www.company.com" could nginx cause the issue?

maybe this has something to do with it? http://stackoverflow.com/a/11353159

Demian Rihs
on 8/18/16, 8:43 PM

I do have the same problem with one of my domains: www.gastrosoftware.ch/page/contactus but it works flawlessly with others such as www.flohmarkt-zug.ch/page/contactus

I'm using caddyserver (www.caddyserver.com) as proxy server for both and I have to investigate the cause.

Ermin Trevisan
on 8/19/16, 2:49 AM

I did check again, I do have the same vhost configuration for both, I do have defined the web.base.URL system parameter defined the same for both. The only difference: the one working is delivered using cloudflare, the other one not working does not use cloudflare :-(

Ermin Trevisan
on 8/19/16, 2:59 AM

I am hosting my odoo instance on an Amazon EC2 instance routing the DNS from my swiss server. I don't know about cloudfare

Demian Rihs
on 8/19/16, 3:26 AM

Both of my domains are hosted on the same DNS hosting provider (hoststar.ch) on the same own Amazon EC2 instance on the same Odoo instance using dbfilter.

Ermin Trevisan
on 8/19/16, 3:42 AM
0

For static maps, you have to :
1-  Enable your project at this url :
https://console.developers.google.com/apis/api/static_maps_backend/overview?project= 

2-  Generate an API Key on the same url 

3-  On odoo, create a system parameter with key = google_maps_api_key and value = [value of API Key generate above]

Hello, thanks for your instructions! I tried this steps but still couldn't get the maps to show up again. It doesn't depends on my host, I also tried with different ones and I get the same results.

Demian Rihs
on 12/16/16, 3:48 PM

Your Answer

Please try to give a substantial answer. If you wanted to comment on the question or answer, just use the commenting tool. Please remember that you can always revise your answers - no need to answer the same question twice. Also, please don't forget to vote - it really helps to select the best questions and answers!

About This Community

This platform is for beginners and experts willing to share their Odoo knowledge. It's not a forum to discuss ideas, but a knowledge base of questions and their answers.

Register

Odoo Training Center

Access to our E-learning platform and experience all Odoo Apps through learning videos, exercises and Quizz.

Test it now

Question tools

1 follower(s)

Stats

Asked: 8/18/16, 8:36 PM
Seen: 649 times
Last updated: 9/20/16, 2:02 PM