Help

Creating Supplier / Contacts Management

Closed
Avatar
Ashley Marc

The question has been closed for reason: off-topic or not relevant

by
Fabien Pinckaers (fp)
on 04/17/2013 03:15:49

Would appreciate if someone is able to help perhaps suggest if i should report this as a bug. Firstly, no issue with creating contacts from the supplier template however, these contacts created appear as customers when the customer box is not ticked while creating the supplier.

Secondly, once the contact is created and opened, the accounting tab is activated and accounting properties such as (Default Debit / Credit accounts) need to be filled in. In my opinion, contacts should not be auto generated into the customer / supplier template.

3 Comments
Avatar
Discard

helo, these are bugs that are being fixed. (we already have a branch that fixed what you reported, it should merged in a few days) So, I close the question, follow on launchpad.

Avatar
Holger Winkelmann
-

just a quick question,ist his fixed in 7.0 already. In latest trunk on runbot I can add a company which has a parent company (I think this shows the fix as it is now) but in my 7.0 installed from lauchpad the functionality has not arrived yet (if I tick "is Company" I cant choose a parent)

Avatar
Henning Hausenberg
-

Hi...I still got the same issue when creating new contacts. What can I do to get rid of that bug? OpenERP tells me no updates available...

3 Answers
2
Avatar
Raphael Valyi
Best Answer

Hello,

the issue is larger than just for suppliers and it has been largely debated ultimately and OpenERP SA even started to admit there is an issue. See bug and discussion here:

(put http:// in front) bugs.launchpad.net/openobject-addons/+bug/1160365

I also started to code a monkey-patch module that brings a new contact_id field on every OpenERP business documents so that you can use it for arbitrary contact while an on_change properly sets the regular partner_id field, ensuring that only the related commercial entity goes here (that is the related company or physical person). Hence, invoices will be using companies, not the contact which BTW kills reporting. Here is the announce of the beta version of this module:

(put http:// in front) bugs.launchpad.net/openobject-addons/+bug/1160365/comments/27

In any case, yes, there is sadly a bad issue about this in OpenERP v7 and the scariest is the way they plan to "fix" it as it's debated in the bug tracker.

Hope this helps.

Avatar
Discard
0
Avatar
Tom Arnst
Best Answer

I came across the same thing, this is clearly a bug, so please report it as such.

2 Comments
Avatar
Discard
Avatar
Yaroslav
-

And this should a comment not an answer.

Avatar
Tom Arnst
-

Hi .. no the question is "Would appreciate if someone is able to help perhaps suggest if i should report this as a bug" !

0
Avatar
Ashley Marc
Best Answer

Bug #1128656

** Changed in: openobject-addons

Importance: Undecided => Low

** Changed in: openobject-addons Status: New => Confirmed

** Changed in: openobject-addons Assignee: (unassigned) => OpenERP R&D Addons Team 1 (openerp-dev-addons1)

Avatar
Discard