Odoo Help

0

0
15 Answers
0
ESLAM ElGINDY Egypt
11/21/17, 3:43 AM

how can i got all this snippets to my odoo web builder

3 Comments
Ilusoria SAS, Ilusoria Colombia
11/21/17, 8:19 AM

I quitted to search a solution for this, actually I prefer Odoo 11, but if someone answers this question could help a lot of people, even if I find something I'll to post the answer.

meanwhile, I'm still with this issue on my Odoo 10 production instances.

ESLAM ElGINDY Egypt
11/21/17, 9:31 AM

i didn't have all this snippets in my v 9 and v 10 how can i found this extra snippets

Ilusoria SAS, Ilusoria Colombia
11/21/17, 10:59 AM
Try installing web apps addons, there are some default snippets modules.

2017-11-21 9:31 GMT-05:00 ESLAM ElGINDY <esgindyg@gmail.com>:

i didn't have all this snippets in my v 9 and v 10 how can i found this extra snippets

--
ESLAM ElGINDY


Sent by Odoo S.A. using Odoo.


0
Avatar

Ermin Trevisan Switzerland

--Ermin Trevisan--
16464
| 8 7 10
Walchwil, Switzerland
--Ermin Trevisan--


Ermin Trevisan Switzerland
5/18/17, 3:09 PM

To me this looks like 2 issues:

- check if all the same modules are installed in the different databases (the customer references snippet for example is missing in the production setup)

- do update all website/snippet modules (some modules and snippets have new names and icons)

12 Comments
Ilusoria SAS, Ilusoria Colombia
5/18/17, 3:59 PM

Ermin, I updated all modules multiple times in different instances and databases and the snippets just are in dev database, I still not know why.

Ilusoria SAS, Ilusoria Colombia
5/18/17, 4:03 PM

When I run a specific database using development parameters the snippets appear.

twanda AG, Ermin Trevisan Switzerland
5/18/17, 4:10 PM

I do not know what that should mean. From my experience (because it is easy to overlook it) I only know that it is the same, when the same modules with the same versions are installed.

twanda AG, Ermin Trevisan Switzerland
5/18/17, 4:14 PM

Did you also check the addons folders (access rights for example) etc.?

twanda AG, Ermin Trevisan Switzerland
5/18/17, 4:15 PM

Directory owners, permissions, users, groups?

Ilusoria SAS, Ilusoria Colombia
5/18/17, 5:18 PM

Yes sir, is pretty estrange because development mode reads de xml files directly, and its when the snippets appear, but in productions all is into database and cache and the snippets disappear, I don't know if is a setting error or a bug, what to do? I don't know :-(

Ilusoria SAS, Ilusoria Colombia
5/18/17, 5:20 PM

Ermin, do you have all snippets in your website builder's panel in one of your instance or database for production?

twanda AG, Ermin Trevisan Switzerland
5/18/17, 5:30 PM

Yes, all (and even more, because I have all Odoo themes installed). But I have deployed my production server with Odoo's package installer on Ubuntu 16.04.

Ilusoria SAS, Ilusoria Colombia
5/19/17, 9:47 AM

mmmm, I'm using git repo, may is that the problem? is some frustrating.

twanda AG, Ermin Trevisan Switzerland
5/19/17, 11:50 AM

I don't believe so. I assume it is a deployment issue. You'll have to compare your deployments step by step...

Ilusoria SAS, Ilusoria Colombia
5/19/17, 4:24 PM

I don't know what's wrong, I've been studying a lot of documentation before do my first deployment, and I learn how to do it better and faster, I'm almost sure that the most dificulte thing was set up the custom domain for one of my clients.

I really dont know what could be wrong in the deployment, It's pretty estrange tha my custom snippets and some snippets from odoo don't show up,a thing that I evidenced was that if I put the snnipet code directly into html editor, website interpretates the snippet, then I can configure it like if snippet have been drag and dropped from website builder's panel.

Ilusoria SAS, Ilusoria Colombia
5/24/17, 7:03 PM

I've been lookup what provoke this issue and I found something interesting:

https://ibb.co/eZ8miF

The code html that generates odoo is this, Is some kind of bug, I really don't know what this means.

I reviewed the snippets.xml code from website module and everything looks to be ok.

Ask a Question
Writer
Keep Informed
1 follower(s)
About This Community

This platform is for beginners and experts willing to share their Odoo knowledge. It's not a forum to discuss ideas, but a knowledge base of questions and their answers.

Register
Odoo Training Center

Access to our E-learning platform and experience all Odoo Apps through learning videos, exercises and Quizz.

Test it now